[SOLVED] Another "Failed to load Collabora Online - please try again later" problem

A few days ago I installed Nextcloud snap on Ubuntu Server 20.04.2 LTS and Collabora Online + Built-In CODE Server was working perfectly. Ports 80 and 443 forwarded to the server, with a registered domain name and LetsEncrypt certificate. Running a split DNS setup and working from the LAN and the internet very nicely.

Today after rebooting Collabora times out and gives the error “Failed to load Collabora Online - please try again later”. So I tried disabling/reenabling Collabora Online and Built-In CODE Server, no luck. Tried removing & re-downloading both, still no luck. After spinning my wheels I removed the snap and installed a new one, no luck.

In admin > Settings > Administration> Collabora Online there is a green checkmark next to “Collabora Online server is reachable” however if I click the radio button next to “Use the built-in CODE - Collaborata Online Development Edition” the checkmark changes to a red circle with a X in it and the message becomes “Could not establish connection to the Collabora Online server.” Oddly, refreshing the page resets it to the green checkmark. This all seems like a clue to me but I have no idea what to make of it.

/var/snap/nextcloud/current/logs/nextcloud.log has a number of entries that look like this:

{"reqId":"AoKHQ76vnhWFVrEUleZG","level":3,"time":"2021-03-20T19:25:53+00:00","remoteAddr":"192.168.xx.xx","user":"admin","app":"richdocuments","method":"GET","url":"/index.php/apps/richdocuments/index?fileId=11&requesttoken=kzmPMdvKp1svfUWxgliH6eznSMsoAmKUVdMfhgx0AIQ%3D%3A20rXdZym1g1OMjOJ1iHTu7mvLLJyQCPEO5hz%2FEhHQbw%3D","message":{"Exception":"Exception","Message":"Could not find urlsrc in WOPI","Code":0,"Trace":[{"file":"/var/snap/nextcloud/26881/nextcloud/extra-apps/richdocuments/lib/TokenManager.php","line":217,"function":"getUrlSrc","class":"OCA\\Richdocuments\\WOPI\\Parser","type":"->","args":["application/vnd.openxmlformats-officedocument.wordprocessingml.document"]},{"file":"/var/snap/nextcloud/26881/nextcloud/extra-apps/richdocuments/lib/Controller/DocumentController.php","line":256,"function":"getToken","class":"OCA\\Richdocuments\\TokenManager","type":"->","args":["*** sensitive parameters replaced ***"]},{"file":"/snap/nextcloud/26881/htdocs/lib/private/AppFramework/Http/Dispatcher.php","line":169,"function":"index","class":"OCA\\Richdocuments\\Controller\\DocumentController","type":"->","args":["*** sensitive parameter replaced ***",null]},{"file":"/snap/nextcloud/26881/htdocs/lib/private/AppFramework/Http/Dispatcher.php","line":100,"function":"executeController","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->","args":[{"__class__":"OCA\\Richdocuments\\Controller\\DocumentController"},"index"]},{"file":"/snap/nextcloud/26881/htdocs/lib/private/AppFramework/App.php","line":152,"function":"dispatch","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->","args":[{"__class__":"OCA\\Richdocuments\\Controller\\DocumentController"},"index"]},{"file":"/snap/nextcloud/26881/htdocs/lib/private/Route/Router.php","line":309,"function":"main","class":"OC\\AppFramework\\App","type":"::","args":["OCA\\Richdocuments\\Controller\\DocumentController","index",{"__class__":"OC\\AppFramework\\DependencyInjection\\DIContainer"},{"_route":"richdocuments.document.index"}]},{"file":"/snap/nextcloud/26881/htdocs/lib/base.php","line":1008,"function":"match","class":"OC\\Route\\Router","type":"->","args":["/apps/richdocuments/index"]},{"file":"/snap/nextcloud/26881/htdocs/index.php","line":37,"function":"handleRequest","class":"OC","type":"::","args":[]}],"File":"/var/snap/nextcloud/26881/nextcloud/extra-apps/richdocuments/lib/WOPI/Parser.php","Line":54,"CustomMessage":"--"},"userAgent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.192 Safari/537.36 OPR/74.0.3911.218","version":"20.0.8.1"}

“Could not find urlsrc in WOPI” seems interesting but again I have no clue where to go from here.

Any thoughts on troubleshooting this problem would be tremendously appreciated.

You are not alone.

“Could not find urlsrc in WOPI” - same here. Last two versions are broken for me.

Reported it in the issue tracker. Issue has been reopened.

I have now manually downgraded to v6.4.608. With this version it is working again.
Nextcloud 20.0.8
Collabora Online - Built-in CODE Server 6.4.608

Thanks I will give this try. Any ideas how to manually downgrade the snap? I am only familiar with installing apps from admin > apps which is preset to the latest version ( 6.4.703). The github install instructions don’t work on the snap version.

UPDATE: Easy to do: download and unpack v6.4.608 into /var/snap/nextcloud/current/nextcloud/extra-apps. It will appear in admin > apps where it can be enabled. Thanks AlfredSK

3 Likes

Btw. the issue (on GitHub) has been fixed. New version 6.4.705 works for me.

Good to know. Have you noticed any tangible benefits over 6.4.608?

1 Like

For me the 6.4.705 is NOT working.
@PatPend thanks for the explanation how to downgrade to v6.4.608
This version is working for me.

2 Likes

After the latest Collabora 3.7.18 update with Collabora Online - Built-in CODE Server 6.4.705 on Nextcloud 20.0.8 (installed via snap) on Ubuntu 20.04 it’s still not working.

As for @Gery_Alaerts , CODE 6.4.705 was not working for me with Collabora version 3.7.18 (never tried Collabora before, installed them both from the “app store” in Nextcloud). My system is running Ubuntu 18.04.4 LTS, and Nextcloud as a snap, v. 20.0.8. Downgrading to 6.4.608 as per @PatPend’s instructions solved it for me.

Hello,

i use Nextcloud 21.0.2, Collabora Online 4.0.4 and Collabora Code Server 6.4.8.1
But it is not working.
Same Error:
Faled to load Document.

install Collabora Code Server 6.4.6.8 is not the solution for me.

any sugesstions?

1 Like

i found a workaround.

the problem is describet here:
Files on SMB-share corrupted while up- and downloading · Issue #26457 · nextcloud/server · GitHub

you have to replace this folder:
/var/www/nextcloud/apps/files_external/3rdparty/icewind
with one of a backup NC 20.0.8 or bevore.
i tested it with a backup from my previous NC 20.0.5 and it is working again now.

good luck

My snap has now updated to version 21.0.1, also the Collabora Online - Built-in CODE Server has updated to version 6.4.806. Again the same problem “failed to load Collabora online”. I have manualy downgraded the Collabora Online - Built-in CODE Serverto version 6.4.608.
Any idea when this will be fixed?

Hey,

you need to override the folder Icewind form backup again.

cu

Not sure if I have a backup of 20.0.8 or before, or ist it automatically created with snap?

Very disapointing that Collabora is still not working with the new version 6.4.1003. :unamused:
I still have to downgrade to version 6.4.608

Can anyone help me with a more detailed instruction to get collabora work on my snap nextcloud? It would be very much appreciated!

@peterschmidler
Check the post of @PatPend

  • Download the v6.4.608 of the richdocumentscode package
  • copy the package in /var/snap/nextcloud/current/nextcloud/extra-apps
  • replace the newer version with the command ‘tar -xf richdocumentscode.tar.gz’

collabora should work once you have this version installed. Off course as soon as you upgrade to the newer version collabora will fail again.

Same with version Collabora Online - Built-in CODE Server
6.4.1004
Still not working

1 Like

Quick question:

Where do you get the older tarballs of the Collabora online and the CODE server? What URL do you go to?