[SOLVED] Another "Failed to load Collabora Online - please try again later" problem

Have a look to the post from @PatPend
You only need to downgrade the Built-in CODE Server
You can use the latest Collabora Online without any problem.

I hope this is the correct url.
https://github.com/CollaboraOnline/richdocumentscode/releases

Just installed Nextcloud via snap on brand-new Ubuntu 20.04.2 server. Despite trying various things, I am unable to downgrade the “Collabora Online - Built-in CODE Server”.

If I extract the tar to the …/extra-apps folder, I see it showing me the app listed as the old version on the …/settings/apps page, but the buttons there are “Remove” and “Download and enable”. Choosing the latter will always get the latest for me. Other times in my fiddling with replacing that folder, the web app goes into update mode and gets the new version of that despite wanting what I had there before.

What am I doing wrong?

Try the following steps:

  • first install (download and enable) the latest version via the GUI interface.
  • extract the tar in the extra-apps and make sure you overwrite the files from the latest version.

After a few moments the GUI interface will tell you that it is installing a new package. After the installation the older version is installed and in the GUI you will see that there is a newer version available.

@Gery_Alaerts That worked exactly as you described. Thank you.

jtkouz@nextcloud:~$ wget https://github.com/CollaboraOnline/richdocumentscode/releases/download/6.4.608/richdocumentscode.tar.gz
sudo su
<Enter password>
root@nextcloud:/home/jtkouz# cd /var/snap/nextcloud/current/nextcloud/extra-apps/
root@nextcloud:/var/snap/nextcloud/current/nextcloud/extra-apps# tar xvf /home/jtkouz/richdocumentscode.tar.gz

Then the GUI showed the update screen, which scared me, but it then said it was upgrading this component to 6.4.608 and the web editing of an ODT file worked great.

Hi - I was running Nextcloud 21 (on Ubuntu 20.04, and via the snap package) and this thread helped me get Collabora to work - I downgraded the CODE server to version 6.4.608 as suggested and all was up and running fine. However, with the snap having upgraded to Nextcloud version 22, this seems no longer to be an option. The snap has Collabora online version 4.2.3 and CODE server 6.4.1103, which throws up the familiar message “Failed to load Collabora Online - please try again later” when you try to open a document through the web interface, and the line “Could not find urlsrc in WOPI” in the logs. However, the 6.4.608 version of the CODE server now shows in the apps as no longer compatible with Nextcloud 22 and so is disabled. Does anyone know, is there a version of the CODE server which is compatible with the current version of Nextcloud and gets Collabora up and working?

@jtkouz
You can still use the ‘unsupported’ version v6.4.608. Just follow the steps I have described in a earlier post.

Thanks so much for your help Gery_Alaerts - yes, that worked - I re-downloaded and enabled the ‘unsupported’ version as you suggested (in spite of warnings), and this has got the Collabora web interface up and running again. Many thanks!

If there’s someone out there who is looking further into this issue, one thing I spotted was a post (Collabora failure when using Snap on Ubuntu SERVER but it works on Ubuntu DESKTOP) which noted this not working on snap on ubuntu server, but working on ubuntu desktop. Interestingly, I’ve basically had the same experience - I initially set up nextcloud via snap on a machine on my own network on a machine with Ubuntu 20.04 desktop, and collbora works fine on that (and still works fine after the latest updates, with the versions of Collabora and Collabora CODE server that are not working on the Ubuntu server version I set up on the ‘cloud’. Both were basically set up in the same way with lets-encrypt, etc. I hope this bit of data helps someone work out why the more recent versions of the CODE server don’t work on my install, or the various other people with snap or docker who are having similar problems. Could there be some kind of dependency that is there on the desktop but not the server? Or something in the latter which conflicts, and that is missing from the former?

Thanks for this topic I was able to solve my initial problem on Ubuntu Server + Nextcloud Snap to downgrade the “Collabora Online - Built-in CODE Server”.

However, like stated above on desktop variants of Linux the built in server works out of the box with no issues. Surely a dependency is missing (introduced somewhere after v6.4.608) which causes issues on Ubuntu Server.

So I thought why not install LibreOffice on Ubuntu Server and see what happens… and guess what the latest version of Collabora working is working fine now in Nextcloud. I unfortunately don’t have to expertise to narrow this down to a single dependency, but maybe someone can pick it up from here.

1 Like

Apologies for coming back to this issue, but I haven’t been able to solve it despite following @Gery_Alaerts post’s instructions.

I receive the message “Failed to load Collabora Online - please try again later”.

I have Nextcould 23 installed (snap, on a Raspberry Pi), and in the active apps list I have Collabora Online CODE (ARM64) v. 6.4.608 (and Collabora Online, obviously).

Anyone can help? :slight_smile:

Edit: I just realised I am running NC version 22.2.3.0 - apparently the Snap package hasn’t updated to v.23 yet.

@pierat

No need to install an older version of Collabora on the nextcloud snap. The default installed ones: Collabora Online 4.2.3 and Collabora Online - Built-in CODE Server 21.11.6 are working fine. At least its working fine for me on a Ubuntu server.

I manually updated CODE to v. 21.11.6 (the latest one available from the NC GUI was 21.11.4); disabled and enabled both Collabora Online (v. 4.2.3) and CODE. Still the same issue:
“Failed to load Collabora Online - please try again later”.

Is there a way to debug it to see what’s wrong?

I recently installed NC 23 Hub II on a V-Server with 4 vCore and 8 GB RAM at the hosting service Strato.de. I installed the Collabora app and the CODE server. While loading an *.odt document I get the error message: “Document loading failed. Try again later.”
RAM is enough but I’m afraid that the server (virtual server) is not suffiend enough. I tried the Collabora demo server and that works fine. Back to CODE I get the same error message.

Sadly, my rented server is to small for that. But I don’t use LibreOffice often, so I deleted it from NC. But that could possibly be the issue on the Raspberry Pies. Perhaps in some time I will use a bigger server (My whole family use it) and maybe CODE will works then.

Hi,
I’m expiring the same issue - every try to open a file with the built-in CODE server ends up in error “Failed to load Collabora Online - please try again later”

Looking into the error console of the browser i see 502 Proxy Errors and therefor I looked directly onto the server. There I tried to run the Collabora_Online.AppImage as user www-data and I’m getting a “permission denied” error.
Looking at the file permissions i see: -rw-r--r-- and this seems pretty strange to me… Modifying the permissions lets me start the AppImage but then I get an other error (that maybe is connected to some other work happened lately on my server and I think this isn’t happening to everyone).
Could someone maybe confirm that the permissions have changed with the last update of CODE to Version 21.11.103?

Hi, I recently open a threat with this problem, but I am not runing on docker or snap. I see that my permissions of my CODE built-in and collabor app are www-data:www-data and “-rwx r-x r-x” at the root folders. The files inside are “-rw- r-- r–” with same user and group

1 Like

Hi!!

I just solved my problem adding the line
’allow_local_remote_servers’ => true,
to my config.php, restart apache (systemctl restart apache2) and now it is working!!!

Hope it be helpful!

3 Likes

Thanks a lot for your reply - unfortunately this didn’t changed anything in my situation :man_shrugging:.
As before the last CODE Update everything has worked without problems i have a suspect that this could have generated the problem…
The missing permission to execute the AppImage from shell is also strange - before the update this seemed to work. Maybe this has been changed intentionally…

I use the Docker Collabora not the Appimage but updating my Nginx (https://sdk.collaboraonline.com/docs/installation/Proxy_settings.html#reverse-proxy-with-nginx-webserver) solved it for me. They changed “lool” to “cool” which broke literally everything in the reverse proxy plus changed the “static files” location.

Copying and pasting the changed locations from the link above fixed it for me using 5.0.1 of the app.

1 Like

Hi,

I’ve found the solution for my problem: the process of coolwsd blocked the port on the server… therefore after the update the newly started AppImage couldn’t connect to the port…

Thanks a lot!