Sharing problems

[detail =“Support intro”]

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:


This has been solved! Thanks to NeptuneUK and stratege1401! Short thing short, when changing character collation type, make sure to follow the questions closely. There is some assistance here if needed. (Edit 2: Still not working. See latest post) Nextcloud team, maybe make the docs a little clearer. Besides that, great job on this.

Nextcloud version (eg, 12.0.2): 16.01
Operating system and version (eg, Ubuntu 17.04): Ubuntu 18.04
Apache or nginx version (eg, Apache 2.4.25): 2.4.29
PHP version (eg, 7.1): Php 7.2

The issue you are facing:

When going to the share menu for any file or directory and start typing in an email/contact, Invalid query, please check the syntax. API specifications are here: pops up.
Is this the first time you’ve seen this error? (Y/N):Yes

Steps to replicate it:

See above.

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

Is this in the data or web root directory. Couldn't seem to find in either.

The output of your Apache/nginx/system log in /var/log/____:

Not sure where to find

Someone had a similar issue that I replied with a summary to at Was just scrolling through GitHub’s issue creation and tried running
sudo -u www-data php occ config:list system in both my data and web directories and got segmentation defaults. Is this the issue? Sorry if I’m posting in the wrong place. I’m new to Nextcloud and just installed this and Collabora.

Here is my log and config file (I found this). This is from my live Nextcloud. Link sharing works, just the box where you type in an email/contact to share with doesn’t work and once anything is typed in the box, the above error message is shown.

I got rid of APCu memory caching and no more segmentation defaults, but the sharing issue isn’t solved.

Hi @gotmax,

It looks like you’ve had to convert your NC db to use utf8mb4.

Are you sure that the conversion was completed successfully on your oc_addressbooks tbl?

Which DB are you using? MySQL / MariaDB / Postgres?

This post might point you in the right direction: Innodb_file_format from antelope to barracuda

What’s the output of MYSQL/MARIADB using:

Yes, I did change that to utf8mb4 for emojis as instructed. I’m using MairaDb. I will share that.

I don’t think I did. I will give you that input.


When I typed mysqld it said process was started and never showed the menu. Is there a certain way I need to start mysqld?

Do I type that into the Mariadb prompt or the regular command line? SELECT NAME, SPACE, FILE_FORMAT FROM INFORMATION_SCHEMA.INNODB_SYS_TABLES WHERE NAME like “YOURDBNAMEHERE%”;


You’ll need to got to your maria DB prompt,

Login from the command prompt using: mysql -u root -p
Enter your DB root password when prompted.
at the SQL prompt: MariaDB [(none)]>
enter the statement I posted changing YOURDBNAMEHERE as appropriate forr own NC database name.
Post the result it should look something like:

| yourdbname/oc_accounts | 183 | Barracuda |
| yourdbname/oc_activity | 184 | Barracuda |
| yourdbname/oc_activity_mq | 185 | Barracuda |
| yourdbname/oc_addressbookchanges | 186 | Barracuda |
| yourdbname/oc_addressbooks | 194 | Barracuda |
| yourdbname/oc_appconfig | 197 | Barracuda |
| yourdbname/oc_authtoken | 200 | Barracuda |
| yourdbname/oc_bruteforce_attempts | 203 | Barracuda |
| yourdbname/oc_calendar_invitations | 206 | Barracuda |
| yourdbname/oc_calendar_resources | 209 | Barracuda |
| yourdbname/oc_calendar_rooms | 212 | Barracuda |
| yourdbname/oc_calendarchanges | 215 | Barracuda |
| yourdbname/oc_calendarobjects | 218 | Barracuda |
| yourdbname/oc_calendarobjects_props | 221 | Barracuda |
| yourdbname/oc_calendars | 224 | Barracuda |
| yourdbname/oc_calendarsubscriptions | 227 | Barracuda |
| yourdbname/oc_cards | 230 | Barracuda |
| yourdbname/oc_cards_properties | 233 | Barracuda |
| yourdbname/oc_collres_accesscache | 236 | Barracuda |
| yourdbname/oc_collres_collections | 239 | Barracuda |
| yourdbname/oc_collres_resources | 242 | Barracuda |
| yourdbname/oc_comments | 245 | Barracuda |
| yourdbname/oc_comments_read_markers | 248 | Barracuda |
| yourdbname/oc_credentials | 251 | Barracuda |
| yourdbname/oc_dav_shares | 254 | Barracuda |
| yourdbname/oc_directlink | 257 | Barracuda |
| yourdbname/oc_federated_reshares | 361 | Barracuda |
| yourdbname/oc_file_locks | 260 | Barracuda |
| yourdbname/oc_filecache | 263 | Barracuda |
| yourdbname/oc_files_trash | 266 | Barracuda |
| yourdbname/oc_flow_checks | 269 | Barracuda |
| yourdbname/oc_flow_operations | 272 | Barracuda |
| yourdbname/oc_group_admin | 275 | Barracuda |
| yourdbname/oc_group_user | 278 | Barracuda |
| yourdbname/oc_groups | 281 | Barracuda |
| yourdbname/oc_jobs | 284 | Barracuda |
| yourdbname/oc_login_flow_v2 | 287 | Barracuda |
| yourdbname/oc_migrations | 290 | Barracuda |
| yourdbname/oc_mimetypes | 293 | Barracuda |
| yourdbname/oc_mounts | 296 | Barracuda |
| yourdbname/oc_notifications | 299 | Barracuda |
| yourdbname/oc_notifications_pushtokens | 302 | Barracuda |
| yourdbname/oc_oauth2_access_tokens | 305 | Barracuda |
| yourdbname/oc_oauth2_clients | 308 | Barracuda |
| yourdbname/oc_preferences | 311 | Barracuda |
| yourdbname/oc_privacy_admins | 314 | Barracuda |
| yourdbname/oc_properties | 317 | Barracuda |
| yourdbname/oc_schedulingobjects | 320 | Barracuda |
| yourdbname/oc_share | 323 | Barracuda |
| yourdbname/oc_share_external | 326 | Barracuda |
| yourdbname/oc_storages | 329 | Barracuda |
| yourdbname/oc_systemtag | 332 | Barracuda |
| yourdbname/oc_systemtag_group | 335 | Barracuda |
| yourdbname/oc_systemtag_object_mapping | 338 | Barracuda |
| yourdbname/oc_trusted_servers | 341 | Barracuda |
| yourdbname/oc_twofactor_backupcodes | 344 | Barracuda |
| yourdbname/oc_twofactor_providers | 347 | Barracuda |
| yourdbname/oc_users | 350 | Barracuda |
| yourdbname/oc_vcategory | 353 | Barracuda |
| yourdbname/oc_vcategory_to_object | 356 | Barracuda |
| yourdbname/oc_whats_new | 359 | Barracuda |
61 rows in set (0.00 sec)

They should all specify ‘Barracuda’ as the File_Format.

Got ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MariaDB serve r version for the right syntax to use near ‘%”’ at line 1 when typing in your command.

NVM. It is all antelope. How do I fix?

Here is my server version if that helps: Server version: 10.1.38-MariaDB-0ubuntu0.18.04.2 Ubuntu 18.04

I started following, but I’m not sure how to perform step 4 for 10.2 or earlier MairaDB.


Login into your NC server.

Login to you Maria DB: mysql -u root -p (or you may need to use sudo mysql -u root -p)
Enter your DB root password when prompted.
at the SQL prompt: MariaDB [(none)]>
enter the statements from the NC documentation.

You’ll then have a lot of statements with some extraneous | characters (they will be in a table), you need to remove the pipe | characters (you can use a text editor and find and replace it this makes it easier for you) and you’ll end up with a load of SQL statements that look like this, a new one for each table in the database:
ALTER TABLE yourdbname.oc_accounts ROW_FORMAT=DYNAMIC;
Run each one of these at the MariaDB command prompt.
When they are all done exit the MariaDB
Restart Mariadb from the command prompt: sudo systemctl start mysql
You can then rerun the previous SQL statement that shows you the table File_Format, they should all now read ‘Barracuda’.

Continue with the guide form there, running the occ maintenance script.

Oh, okay. That makes sense. I will do later today.

I did this and the issue persists.

So do you mean the sharing issue or the DB ‘Antelope’ => ‘Barracuda’ issue?

If you’re not in a production environment, the easiest path may be to backup (use mysqldump) and delete the current DB, and recreate a new one from the correct point in the NC installation guide.

Remember to set the correct settings in the cnf file and run the correct sql statement for the collation settings:

“CREATE USER ‘username’@‘localhost’ IDENTIFIED BY ‘password’;
CREATE DATABASE IF NOT EXISTS nextcloud CHARACTER SET utf8mb4 COLLATE utf8mb4_general_ci;
GRANT ALL PRIVILEGES on nextcloud.* to ‘username’@‘localhost’;
FLUSH privileges;”

Did you follow that step previously?

I changed everything to Barracuda following your instructions. I changed my character type using the guide, because I checked errors after installing and that was one. When doing it, I didn’t change it from Antelope to Barracuda with those directions because that part was unclear. Should I wipe it out and start over? I prefer not to, but if that is the only way I will.

wipping is not necessary.

When your DB is set to use barracuda, you can do a repair of any old table, witch end up being a recreate of the table, in barracuda format.

I use phpmyadmin or manual option to do it and it work fine for me. (php 7.3.6 maria 10.1)

I don’t have phpmyadmin. I can install it, but is there a way to do it manually? I know phpmyadmin is sometimes subject to security risks and I prefer not to have to deal with those.

Hello again,

I ve being using phpmyadmin 4.8.5 with php 7.3.6 on a 10.1 - Debian 10.0 actually and similar setting over the past 5 years without any troubles ! those security flaws are “excesives” in my personal point of view ( warning, troll possible here :slight_smile: )

I did made in error. It is not a repair witch is need, it is an optimize using following
OPTIMIZE TABLE oc_table_name_here``

command for ALL THE TABLE: from my test bench, i use a lot app, so some may be missing on your system
PTIMIZE TABLE oc_accounts, oc_activity, oc_activity_mq, oc_addressbookchanges, oc_addressbooks, oc_announcements, oc_announcements_groups, oc_appconfig, oc_audioplayer_albums, oc_audioplayer_artists, oc_audioplayer_genre, oc_audioplayer_playlists, oc_audioplayer_playlist_tracks, oc_audioplayer_stats, oc_audioplayer_streams, oc_audioplayer_tracks, oc_authtoken, oc_bruteforce_attempts, oc_calendarchanges, oc_calendarobjects, oc_calendarobjects_props, oc_calendars, oc_calendarsubscriptions, oc_calendar_invitations, oc_calendar_resources, oc_calendar_rooms, oc_cards, oc_cards_properties, oc_circles_circles, oc_circles_clouds, oc_circles_groups, oc_circles_links, oc_circles_members, oc_circles_shares, oc_collres_accesscache, oc_collres_collections, oc_collres_resources, oc_comments, oc_comments_read_markers, oc_credentials, oc_dashboard_events, oc_dashboard_settings, oc_dav_shares, oc_directlink, oc_external_applicable, oc_external_config, oc_external_mounts, oc_external_options, oc_federated_reshares, oc_filecache, oc_files_antivirus, oc_files_avir_status, oc_files_trash, oc_file_locks, oc_flow_checks, oc_flow_operations, oc_groups, oc_group_admin, oc_group_folders, oc_group_folders_acl, oc_group_folders_groups, oc_group_folders_trash, oc_group_user, oc_jobs, oc_ldap_group_mapping, oc_ldap_group_members, oc_ldap_user_mapping, oc_login_flow_v2, oc_migrations, oc_mimetypes, oc_mounts, oc_music_albums, oc_music_ampache_sessions, oc_music_ampache_users, oc_music_artists, oc_music_cache, oc_music_playlists, oc_music_tracks, oc_news_feeds, oc_news_folders, oc_news_items, oc_notifications, oc_notifications_pushtokens, oc_oauth2_access_tokens, oc_oauth2_clients, oc_polls_comments, oc_polls_events, oc_polls_notif, oc_polls_options, oc_polls_votes, oc_preferences, oc_preview_generation, oc_privacy_admins, oc_properties, oc_registration, oc_schedulingobjects, oc_sensorlogger_data_types, oc_sensorlogger_devices, oc_sensorlogger_device_data_types, oc_sensorlogger_device_groups, oc_sensorlogger_device_types, oc_sensorlogger_logs, oc_share, oc_share_external, oc_sociallogin_connect, oc_storages, oc_systemtag, oc_systemtag_group, oc_systemtag_object_mapping, oc_trusted_servers, oc_twofactor_backupcodes, oc_twofactor_providers, oc_twofactor_totp_secrets, oc_twofactor_u2f_registrations, oc_twofactor_yubikey, oc_usage_report, oc_users, oc_users_external, oc_user_saml_auth_token, oc_user_saml_users, oc_vcategory, oc_vcategory_to_object, `oc_whats_new