Sharing file links becoming localhost when downloading

Link becoming localhost

Nextcloud version :latest
Operating system and version (eg, Ubuntu 20.04): Latest
Apache or nginx version: Apache2 2.4.59

The issue you are facing:
So when i installed nextcloud docker container everything kinda runs smootly, i had to make some adjustments to my run command but everything is good. my command:
docker run --name nextcloud -d -p 8008:80 -v /mnt/SSD/General:/data --network nextcloud-net -v /home/pi/nextcloud:/var/www/html nextcloud
this has worked wonders. But i noticed that when i share a file example a normal png file i uploaded my self something wierd happend. It took me to my domain and the download page, where my domain was in the adress bar. When i click download it takes 2 seconds and it redirects me to which is where nextcloud is launched, i use apache2 to proxy it into my domain.

First time ive seen it.

Steps to replicate it:

  1. simply launch my docker command
  2. set up external storage using /data as the path
  3. then share the file and try downloading it on a different computer(it will work doing it on the same computer since is actully hosting something)

what i want:
I want the domain to stay in the bar, this makes it actully downloadable from other computers while also looking nice.
Also a small tutorial on how to find my config while hosting using docker images and contaniers.

hi @ImHotiDog welcome to the forum :handshake:

likely you didn’t setup reverse proxy settings correctly, please review and provide more details as per required support template if you need further help.


1 Like

Would it help with my reverse proxy web file?

also i get to here

but then the next when i click on download:

Namely we need the output of occ config:list system.

Note if you access your Nextcloud via multiple hostnames, sharing will not behave consistently. So if you’re using localhost then sharing, that’s also part of the problem possibly. Use a single hostname to access regardless of where you’re doing it from to avoid sharing issues.