Server has no maintenance window start time configured

List of activated apps
 - activity: 2.20.0
 - admin_audit: 1.18.0
 - bruteforcesettings: 2.8.0
 - calendar: 4.6.4
 - camerarawpreviews: 0.8.4
 - circles: 28.0.0-dev
 - cloud_federation_api: 1.11.0
 - comments: 1.18.0
 - contacts: 5.5.1
 - contactsinteraction: 1.9.0
 - dashboard: 7.8.0
 - dav: 1.29.1
 - federatedfilesharing: 1.18.0
 - federation: 1.18.0
 - files: 2.0.0
 - files_pdfviewer: 2.9.0
 - files_reminders: 1.1.0
 - files_sharing: 1.20.0
 - files_trashbin: 1.18.0
 - files_versions: 1.21.0
 - firstrunwizard: 2.17.0
 - logreader: 2.13.0
 - lookup_server_connector: 1.16.0
 - nextcloud_announcements: 1.17.0
 - notifications: 2.16.0
 - oauth2: 1.16.3
 - password_policy: 1.18.0
 - photos: 2.4.0
 - privacy: 1.12.0
 - provisioning_api: 1.18.0
 - recommendations: 2.0.0
 - related_resources: 1.3.0
 - richdocuments: 8.3.1
 - richdocumentscode: 23.5.705
 - serverinfo: 1.18.0
 - settings: 1.10.1
 - sharebymail: 1.18.0
 - support: 1.11.0
 - survey_client: 1.16.0
 - systemtags: 1.18.0
 - text: 3.9.1
 - theming: 2.3.0
 - twofactor_backupcodes: 1.17.0
 - updatenotification: 1.18.0
 - user_status: 1.8.1
 - viewer: 2.2.0
 - weather_status: 1.8.0
 - workflowengine: 2.10.0
 - encryption
 - files_external
 - files_rightclick: 1.6.0
 - music: 1.9.1
 - spreed: 18.0.2
 - suspicious_login
 - twofactor_totp
 - unsplash: 2.2.1
 - user_ldap

The issue you are facing:

Updated to version 28.0.2 RC5 and I getting this error :slight_smile:

  • Server has no maintenance window start time configured. This means resource intensive daily background jobs will also be executed during your main usage time. We recommend to set it to a time of low usage, so users are less impacted by the load caused from these heavy tasks. For more details see the documentation :arrow_upper_right:.

Is this the first time you’ve seen this error? (Y/N):Y

Cron Configuration: Array
[backgroundjobs_mode] => cron
[lastcron] => 1706722804

External storages: files_external is disabled

Encryption: no


  • OC\User\Database

Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


The output of your Apache/nginx/system log in /var/log/____:



Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

1 Like

Do you have a specific question that isn’t answered by the linked documentation?

It’s just a warning, not an error. It’s up to you whether you want to set it to something.

Setting these to run at a quiet time (often late at night / very early morning) is typical.

Hello jtr,

Thanks for your time.

I read in documentation that I have to edit config.php with maintenance_window_start => 1

Did it but problem not solved.

Am I missing smthing?

'maintenance_window_start' => 1,

Also depending on your web/PHP configuration you may need to wait a minute or so (or restart Apache or FPM for changes to take effect).

Did so… waited apprx 30min. Nothing yet.

thanks for the advice. I will ignore it.

It’s a newer check, but all is does it make sure that parameter has a value and I don’t see any obvious bugs in the code.

Are you sure things are quoted correctly? Can you provide the parsed by running occ config:list system?


ou may use your browser or the occ upgrade command to do the upgrade
    "system": {
        "instanceid": "***REMOVED SENSITIVE VALUE***",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
        "datadirectory": "***REMOVED SENSITIVE VALUE***",
        "dbtype": "mysql",
        "version": "",
        "overwrite.cli.url": "https:\/\/\/",
        "htaccess.RewriteBase": "\/",
        "memory_limit": "1024M",
        "dbname": "***REMOVED SENSITIVE VALUE***",
        "dbhost": "***REMOVED SENSITIVE VALUE***",
        "dbport": "",
        "dbtableprefix": "oc_",
        "mysql.utf8mb4": true,
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "installed": true,
        "default_phone_region": "GR",
        "maintenance": false,
        "theme": "",
        "loglevel": 2,
        "memcache.local": "\\OC\\Memcache\\APCu",
        "memcache.distributed": "\\OC\\Memcache\\Redis",
        "mail_domain": "***REMOVED SENSITIVE VALUE***",
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpmode": "smtp",
        "mail_sendmailmode": "smtp",
        "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpport": "587",
        "mail_smtpsecure": "tls",
        "mail_smtpauth": 1,
        "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
        "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
        "maintenance_window_start": 1

Tengo el mismo inconveniente todo andaba de maravilla sin alertas o errores hasta esta nueva actualización no se que deba modificar para resolverlo me gusta ver todo perfecto

"version": "",

That can’t be your active configuration. It’s for NC25! :slight_smile:

hi guys ,did u resolve this problem?
i get same one ,when i update to 28.0.2

There’s a link in the warning message to the documentation

You have to add the following line line to your config.php:

'maintenance_window_start' => 1,

1 stands for the hour when you want the maintainenance window to start in UTC time, so in the above example the maintainenance window starts at 01:00 UTC Time.

Nextcloud Documentation:

What is UTC time?:

UTC time zone converter:


Amigo exactamente en que lugar de la configuracion php debe ir
‘maintenance_window_start’ => 1,

Anywhere except in an array. If you want to be on the safe side, place it in the second last line above the );

Or you could use the occ config command.


sudo -u www-data php /path/to/nextcloud/occ config:system:set maintenance_window_start --value="1" --type=integer`

mil gracias esa era la solución vuelvo a tener todo en orden

1 Like

Worked for me
‘maintenance_window_start’ => 1, in the Config.php file
be sure to restart apache2 and PHP (as applies) and then reboot.
Notice gone


What you mean it’s I am updating again to check!

it is really work now, thank you very much.


Still the same. I updated to 28.0.2, restarted apache and php service, waited for a day.

@huhas12 The configuration you posted yesterday was for NC25. Are you sure you’re modifying your live configuration? Or perhaps do you have a second Nextcloud Server installation active?

It would have been nice to add this parameter to the configuration page before adding the warning about it, especially since it needs to be in UTC, making it really easy to set an inappropriate time. Can we get a selector in the configuration when CRON method is selected that allows setting this parameter using a local time selector?

1 Like