Secure Outlook add-in is now available for testing in free-as-in-beer version


#143

I have the same problem error " the settings are incorrect. please check the server url, username, and password". My current setup is as follows. Ubnutu server 16.04 with current build of Nextcloud v12. Using self signed certificate. Configured to do LDAP lookup (Running windows 2016 server) . It is setup internally for now. Using the latest build of outlook plugin. I can login to the web interface with LDAP users no problem but when configuring the outlook I get the error as indicated above. I have also imported the cert. Also, I tried a local user and not a user from LDAP look up same problem. It seems to be hanging up on the URL. I copied and pasted the url. Is there any logs so I can get more details?


#144

Sorry for the late reply!

@oskarma That part of the translation is hard-coded, as the customization of that part is a commercial feature.

@JimmyKater You can PM me if you want. Also please check that after or during your upgrade things like a “App passwords” are not enabled, that could explain it.

@2nutz4u You can PM me if you want. Usually self-signed certificates are the issue, please make sure your self-signed certificate is installed on machine as a trusted root certificate. You can enable logging using the (new email > Nextcloud tab > Settings > Advanced enable debug and restart Outlook). When you try to connect then it will write a log to your documents folder.


#145

Hello,

since 2 month we get this:
05.03.2018 14:41:23: URL REQUEST: https://www.edg-bigdata.de/ocs/v1.php/apps/files_sharing/api/v1/shares - METHOD: POST - CONTENT: path=/Outlook/Upload-Files/20180305/fd81a684ecfa4354982433590abfbf99;password=XXXXXXXXXX;shareType=3;expireDate=20180404
05.03.2018 14:41:23: Content: path=/Outlook/Upload-Files/20180305/fd81a684ecfa4354982433590abfbf99&password=XXXXXXXXXX&shareType=3&expireDate=20180404
05.03.2018 14:41:24: Der Remoteserver hat einen Fehler zurückgegeben: (401) Nicht autorisiert.

Nobody changed anything, exept the NC13 Update. But my private NC13 is running fine with the plugin.
Any ideas whats wrong?

Thank you in advance


#146

Hi, you strongly should remove the cleartext passwords from your output!!

Kind regards


#147

Doesn’t matter the share wasnt created thanks to the error.
But anyway, thank you for the advice^^


#148

@Oliver_Kahle Can you try removing the whole key from the registry (Computer\HKEY_CURRENT_USER\Software\NextcloudOutlookFE). Restart Outlook, this will make you log-in again. For some reason this looks like can be related (webdav path api output differs?).


#149

I shall try later (from outlook) because I use Linux OpenSuse and I use
Thunderbird currently.

I have delete a lot of time the calendar and create with the 2 defaults
configuration links… never succes.

The same result on Windows and on Linux, always with thunderbird.

Login problem and low low connexion… it’s really booring from 1-2 weeks
ago.


#150

So the conclusion… for me…
I try the calendar with Evolution and … tada … first try, win !!

So this is the calendar plugin from Thunderbird (Version 52.6.0) the problem.

Thanks for the suggestion. It’s really good idea.


#151

Hi all,

what is the latest available version noe and where can I find it? Are there any bugs or is it running now “out of the box”? :wink:

Thanks!

Regards


#152

Hi,

I just installed the latest available version (20171024) in Outlook 2010 (64bit) and I managed to connect to the server (running 13.0.2), but none of the buttons (Advanced, Share Files, Share Public Folder) work when I click on them. I managed to turn on the logging via regedit, but there’s no error whatsoever.

Any ideas?
Thanks!


#153

Nevermind, I found the problem: I set the “SetLanguage” to “en” (my OS is in french) and now everything works. Will look into creating a fr.json localization if I’ve the time.

Cheers!


#154

@RuiPereira I will look again into the auto determing of the language. If you ever finish the French translation, feel free to PM me :slight_smile:


#155

I am experiencing same symptoms. " The settings are incorrect. Please check the server url, username and password. " with latest version 24-10-2017 and previouse version 18-8-2017.

I have tried oldest version 6-7-2017 which does get past config during initial outlook load, but when trying to upload a file, it simply hangs. when using this older version I can see on my nextcloud server that a random folder name has been created under the outlook>Upload-files share folder, but no contents ever get written.

I am on English (default english). I have tried setting en-EN as advised, but it always resets back to just en

My services are hosted on the web so I have no control over the TLS parts.

Using Outlook 2010 32bit on Windows 7

It almost works with the oldest (6-7-2017) version, but the previous (18-8-2017) and newest (24-10-2017) versions fail in the same way.

Any ideas to try?

Here is a log entry of the debug;
17/05/2018 15:22:20: Logging Activated!
17/05/2018 15:22:21: Initializing language: en-GB
17/05/2018 15:22:21: URL REQUEST: https://{server url}/ocs/v2.php/cloud/capabilities - METHOD: GET - CONTENT: NULL
17/05/2018 15:22:52: Encrypt result: {pass hash}
17/05/2018 15:22:52: Reading settings…
17/05/2018 15:22:52: Decrypt input: {pass hash} - {username}
17/05/2018 15:24:33: URL REQUEST: https://{server url}/ocs/v2.php/cloud/capabilities - METHOD: GET - CONTENT: NULL
17/05/2018 15:24:43: application/pdf - application-pdf
17/05/2018 15:24:44: Uploading…
17/05/2018 15:24:44: WebDavCmd: https://{server url}/remote.php/webdav/Outlook/Upload-Files//20180517 - Command: PROPFIND
17/05/2018 15:25:04: Encrypt result: {pass hash}
17/05/2018 15:25:04: Reading settings…
17/05/2018 15:25:04: Decrypt input: {pass hash} - {username}
17/05/2018 15:25:16: The remote server returned an error: (404) Not Found.
17/05/2018 15:25:16: WebDavCmd: {server url}/remote.php/webdav/Outlook/Upload-Files//20180517 - Command: MKCOL
17/05/2018 15:25:44: application/pdf - application-pdf
17/05/2018 15:25:47: WebDavCmd: https://{server url}/remote.php/webdav/Outlook/Upload-Files/20180517//ca7f1ab1ea7b42e58c0f60bd7129f494 - Command: PROPFIND
17/05/2018 15:25:48: The remote server returned an error: (404) Not Found.
17/05/2018 15:25:48: WebDavCmd: https://{server url}/remote.php/webdav/Outlook/Upload-Files/20180517//ca7f1ab1ea7b42e58c0f60bd7129f494 - Command: MKCOL
17/05/2018 15:25:48: URL REQUEST: https://{server url}/ocs/v1.php/apps/files_sharing/api/v1/shares - METHOD: POST - CONTENT: path=/Outlook/Upload-Files/20180517/ca7f1ab1ea7b42e58c0f60bd7129f494;password=Bkttb6;shareType=3;expireDate=20180518

Server name has been replaced throughout with {server url}
Username has been replaced throughout with {username}
password hash has been replaced throughout with {pass hash}

Seems the 404 not found is the issue, however the structure is correct. (except for the double //)

Regards
Jason


#156

Hello,

so I tried the latest x86 version (20171024) on Win 10 (x64) with OL 2016 (x86) but it is still not working.
Seems that there are still the same problems as half a year ago with Win7 and OL 2013. :neutral_face:

I don’ get what the problem is… is the plugin not the same as the commercial one, but with feature restrictions?

When I start writing a new e-mail I see the buttons, I upload a file but my NC shows only a share with folders and still no file inside. Also there is no information in my e-mail copied. So I starting again a that point where I was half a year ago :cold_sweat:

Help!

Thanks!

Regards

PS: I forgot to mention: The installer says version 2.1, but when I look in Windows software deinstallation it says version 1.5.0. ?


#157

When I open a mail send out using the plugin I get a “phishing” warning in thunderbird.

This makes the whole message look like a security issue and not a gain in security. Is there a way to prevent the mails from triggering the “phishing-prevention” within thunderbird?

Best regards
Norbert


#158

@codec:

Hi,

just to understand it correct: Your mail was sent with Outlook / Outlook add-in and you receive th email via Thunderbird and get a phising warning?

Regards


#159

Yes, that’s exactly what happens sending with Outlook 2010 and receiving with thunderbird 52.8

Regards
codec


#160

@codec the phishing warning is probably triggered due the Nextcloud logo which is inserted which is not apart of your domain. E.g. logo redirects to nextcloud.github.com/somelogourl while your email is codec@example.com. This is probably the reason as why the message shows. I don’t know of a direct solution.

@jason_bullough The failure to upload files is probably related because of the password policy bug which is adressed in the new build. For your second error “settings are incorrect”, this can be related to the brute-force settings.

@blu-IT This might be related to the password-policy bug adressed in the new build.


Brute-force protection issue
Symptom: sometimes the add-in will generate a “Please check the server url, username and password” error. This is probably related to the brute-force protection being triggered (to many api requests). This can happen when many users use Nextcloud (plus add-in).
“If triggered, brute force protection makes requests coming from an IP on a bruteforce protected controller with the same API slower for a 24 hour period”

For the add-in this means that a time-out comes up and therefor it thinks the login failed.
To solve this, install the brute-force settings app and whitelist your network.
https://apps.nextcloud.com/apps/bruteforcesettings


Here is the new build, with versioning… (2.2.0.1)

  • Added; Italian language support
  • Fixed; Password policy bug (affects NC server version 12+)

Addin outlook installed but nothing
Outlook Add-In buttons visible but clicking on them has no effect
#161

@usselite:

Thanks a lot for your effort!!! Now it works! BUT before that I had to reestablish the connection, reentering the nc-password in the addin settings (there was no message that there is a connection problem by the way).
Before that I had the same effect: The addin told me the upload was successful, but there wasn’t even the “Outlook” folder created in my nc (I deleted it wit the the old addin version). So now it works fine!

One more question: Is it possible to define where the addin is saving the uploaded files (path)? E.g. some other folder in my nc than “Outlook” or a complete different naming structure?

Best regards


#162

@usselite:

And another short question: Is it possible to edit the HTML-code for the message output in the addin-settings?
I can see the code, but can’t change it (e.g. for translations - german addin language, but english output in the email).

Thanks!

Regards