S3 Primary + files over 1GB == error


I have Nextcloud running with S3 (Wasabi) as primary storage. This has been working fine until I tried to upload a file that was ~1.7GB which failed. Thinking it was an issue with the Nextcloud client I tried uploading the same file through the web interface which failed with an error regarding reassembling the files. I did some searching and found several similar posts, but they were mostly with larger files (over 4GB) but I went ahead and tried some of the suggestions (i.e. Large files cannot be uploaded when object storage is used as the primary storage) but so far nothing has resolved it.

I do not believe it is a Wasabi limit as I have some single files that are over 200GB there (uploaded with s3cmd and goofys) that are working and verified (md5 and sha sum) to be intact.

Current setup: Ubuntu 22.04 + Apache 2.4.52-1ubuntu4.1 + PHP 8.1+92ubuntu1 + Nextcloud 24.0.3 + PostgreSQL 14.4

Current configs that I think are relevant:

max_execution_time = 0
max_input_time = -1
memory_limit = 2G
post_max_size = 0
upload_max_filesize = 999G
max_file_uploads = 20

$this->uploadPartSize = $params[‘uploadPartSize’] ?? 104857600;
$this->putSizeLimit = $params[‘putSizeLimit’] ?? 104857600;

const PART_MIN_SIZE = 5242880;
const PART_MAX_SIZE = 5368709120;
const PART_MAX_NUM = 10000;

I did try the settings in the above mentioned post:
const PART_MIN_SIZE = 4194304;
const PART_MAX_SIZE = 1073741824;
const PART_MAX_NUM = 1000

The last try was:
const PART_MIN_SIZE = 5242881;
const PART_MAX_SIZE = 5000000000;
const PART_MAX_NUM = 1000

I also have tried a lot of other, different settings for PART__ but most result in an error indicating the size must be between 5MB and 5GB even if the size is in fact inside those ranges for MIN and MAX.

So either I get the error “The part size must be no less than 5 MB and no greater than 5 GB.” OR “Error when assembling chunks” with all of my config test variations.

Thank you for any assistance!