RPi 4 - no mp4 video playback

today I put a fresh NCPi version (Dec. 2019) on my RPi 4 (2GB), to dig into my problem, that I cannot playback mp4 videos. And I likely say, no video, as the “nextcloud intro” video also does not play.
I had the same problem with an brand new version of NCPi. Error message is: “error loading file”.
I cannot believe that I am the only one with this problem! I did not find anything similar here.
Some add information:
RPI 4, 2G, Raspbian up2date, NCPi 1.19.1 (1.24 the same), NC 17.0.2 (18.0.x the same).
If I share the file via link, I CAN play the video on all devices (macos, iOS, chrome & firefox (on Mac).
ffmpeg is installed. (before the same)
Have converted into a bunch of different formats, but doesn`t matter.

Any suggestions are very welcome. Thank you.

They need H.264 with AAC sound

Thanks a lot for your comment!
Typically I use x.264 with AC3 sound (not sure if this is the best choice/combi) and it worked on a RPi 3 and a macos based plex server. Also one of my test-converted files is H.264+AAC, but does not work.
On the other hand, via a shared link, all files are playing properly.

That sounds strange!

Does preview generator work for videos?

Hi Sanook, dear all
I just took the time to set up a simple LAMP stack + Nextcloud18.0.4.
Et voila, all works fine - video playback wise. The whole bunch of different videos formats play flawlessly, beside one .mkv file.
So I conclude, that there is a problem with NCPi. Does anyone have nachoparker`s email :wink:
@Sanook: I will try your suggestions and check the hints from that installation guide.

I am pretty sure mentioning @nachoparker here will do it as well…

Throw an eye on this installation guide:

Did that. Now preview for .mp4 etc. works. But still no playback :anguished:
Hello @nachoparker, where are you? :wink:

Interstingly preview for video files are working for @Paradox551

Update from my further investigations:
All my .mp4s are .x264 & AC3. I am on MACOS 10.14.6 (Mojave). In NC 17.x I could enjoy all my videos. With NC 18.x something changed. Thanks to @Sanook for pointing out to the standard of NC`s video player, which is .x264 & AAC.
Now I made an overview, what does work, what does not.

NCPI 18.0.3 is running on a RPi 4, 2G.
One conclusion can be: To avoid any further conversion I should stay with NC17.

1 Like