Richdocuments Client Error

GuzzleHttp\Exception\ClientException: Client error: GET http://localhost/extra-apps/richdocumentscode/proxy.php?req=/hosting/capabilities resulted in a 404 Not Found response: 404 Not Found

Not Found (truncated…)

Dear All,

I having this issue since installation last year, but until now, I still unable to find any solution for this error log.

Operating System: Linux 5.4.0-167-generic x86_6422.04
CPU: Intel(R) Xeon(R) E-2334 CPU @ 3.40GHz (8 cores)
Memory: 31.20 GB
Type: mysqlVersion: 8.0.35
Version: 8.1.25
Memory limit: 512 MB
Max execution time: 3600
Upload max size: 16 GB

Can anybody help me on this.

Thank you in advance.

Do you also have richdocumentscode (the Built-in CODE Server) installed in addition to richdocuments (the Nextcloud Office Integrator app)? You need both.

The error indicates that either richdocumentscode isn’t installed or it’s not installed where the Integrator app is pointed to load it: http://localhost/extra-apps/richdocumentscode/proxy.php?req=/hosting/capabilities

You can test it yourself by trying to access that URL directly from your browser.

If richdocumentscode is installed, then go to Admin settings->Office and select Use your own server then click Save. Then select Use the built-in CODE again. It should attempt to auto-configure the URL again and may pick up the correct one.

Might need to check your overwrite* parameters/etc in your Nextcloud Server config.php too to make sure they’re all accurate.

The auto-config logic for the the CODE integration has also been finicky at times. There’s been some changes recently (not released yet though I don’t think; were made just last week!) in the auto-config logic that may improve this in the future too. But my manual workaround above should work if your other Nextcloud settings are correct.

Your post is missing any and all specific technical information. Thanks for your post, but please take a little time to get acquainted with the forum and make a stronger effort to troubleshoot. It is the least you can do when asking others to help you:

  • Search your question as keywords on this forum. If you find something useful, link it directly into this post.
  • Search the internet using your issue as generic keywords. Specificity is king:
    • php modules missing Ubuntu Snap update
  • If you have an error message, repeat this process to search for your error on the forum and internet.
  • If you do not find an answer, you are likely using the wrong keywords. Try simplifying your search on the forum and internet even more.
    • nextcloud php modules missing
      Once you’ve done this you should be able to edit and update your post with specific technical information we can use to help you.
  • Check Nextcloud admin documentation

Edit and update your post to include:

  • Direct Links to any useful info pages, posts and other info you find.
  • Add screenshots to your post for context
  • If you have large log files to attach you can link to a pastebin
  • Fill out our support form and add into your post.

These are the exact same steps we volunteers will be following to help you! So, get to it!

unfortunately collabora-built-in doesn’t respect Nextclouds reverseproxy overwrite* settings - if there is a reverse proxy in place it must send correct host headers like X-FORWARDED-*

Take a look at the troubleshooting hints and this wiki Collabora integration - many hints apply to built-in CODE as well.

you have pretty powerful system - increasing memory limit could help as well.

I use the Collabora Online server and its reachable.

I also install Nextcloud Office