Restore nextcloudpi

I want to install nextcloudpi again and restore the previous one.
I have a backup without data (I don’t have space for a backup with data on my HD)
I have already tried to restore, but I have an error.
Can you advise me on the procedure please?

Thanks in advance

You can follow this procedure

thank you for your reply

Here is my situation
nexcloudpi 1.47.2,
raspbian buster
two hard disks, one for data (400go) and the other for backups

I have already tried to upgrade with sudo ncp-dist-upgrade, but unfortunately, there is an error. Then it seems that I have errors on my configuration.
so i thought i’d start with a fresh install of nextcloudpi.
I installed on a new SD card the latest version of nextcloudpi, I put it on my Raspberry taking care to unplug my hard disks not to corrupt them, then from the interface of nextcloudpi https://..***:4443/ I uploaded a backup and I made the restoration, but unfortunately this one failed.
Did I do it right or not?

I have understood why I can’t restore.

I have two disks

  1. the one containing the data (400 GB)
  2. the one that contains the backup (400 GB)

When I do a new installation on a sd card, these two disks are not mounted, so I can’t access the disk that will contain the data to restore the backup.

If I format the disk that contains the date, I’ll end up with nothing, and that stresses me out a lot.

Can you please guide me through the procedure?

So you unfortunately do not have a full backup (data-files are missing) to do a restore.

But you still have the old SD-Card plus the old 400GB-harddrive?
You could try to do a full backup of your old system including the data (using nc-backup like described in OliverV’s link).
When you enable compression, the size of the backup hopefully fit’s to your backup-HDD. If not you should invest in a bigger backup-HDD anyway :wink:

Thank you for your reply,
I have already done this, now I have a full backup
(before, I don’t know why the backup drive that was called “backup” changed its name and is now called “backup1” and the backup was on the wrong drive.

1 Like