Remove the app from ftp or filemanagement of cpanel

I had struggled with collabora and only office etc and installed a bunch of apps and configured them wrongly now my nextcloud does not load anymore I need urgent help
As I installed in shared hosting cpanel I need to disable these apps using file management
no ssh etc
In wordpress it was easy but in nextcloud how to disable the app from file mangement of cpanel or ftp so I can access nextcloud interface and remove the apps finally from there?

Your question has nothing to do with NC. It’s a cpanel-question.

Maybe you after lucky enough to find a solution here as well but I’d rather try it on a cpanel-forum.
Or, depending on your shared hoster and your installation, you might want to ask them for help.

If you do so if you can solve the problem pls don’t forget to tell our forum about the details.

No this has nothing to do with cpanel. I think either due to my poor english I could not explain or you misunderstood ? I know how to work with cpanel that is not what I mean I mean disable app itself

you asked to disable apps from nextcloud without using nc nor the commandline… but doing it with cpanel. right?

afaik you can’t disable apps from nextcloud without either using nextcloud itself nor occ.

so you could try setting up a cronjob with something like the bashcommand to disable apps from nextcloud. THIS would be solved by cpanel.

You maybe can delete all data of said apps from your disk, but it needs to be de-installed from NC as well.

Ok thanks , OK so I create a cron job in cpanel what should I add in it?

the manual tells you how to do that correctly

sudo -u [webuser] php occ app:disable [name of app]

you better run this command in the installing-folder of nextcloud. Usually it is /var/www/nextcloud or /var/www/html/nextcloud (depending on your installprocedure) - I dunno about your installation.

webuser - is the user who owns your installation. Usually this is www-data. Could be different on your installation

my hosting gave me access to ssh and I ran the command from ssh but I receive this

                 Could not open input file: occ

Please note I installed nextcloud from Nextcloud Web Installer on my shared hosting.

did you run if from the correct installing-directory using the correct webuser?

Yes I went to home directory , it did not work I went inside Public_html and that did not work either

So there is not other way to have my cloud back?

Was there an errormessage coming up?

the nextcloud interface does not load at all
As for error message when trying ssh no

Isn’t there any way to get rid of an app any other way so I can save my cloud?

I have a backup but it is a few days old. If I try to restore from backup what exactly do I need to restore so every thing is intact and just effect the apps?

restoring all and everything… maybe you don’t need to restore your data (and hope that you haven’t done too much on your server in the meanwhile). with files:scan your could get the “new” files again. (new) Shares will be lost. As well as everything you did with the database in the meanwhile.

how to restore? Pls refer to the manual for your backup-software.

Thanks . It seems using nextcloud you must do every thing in command line ssh?
How can I do files:scan on nextclud interface?

of course not… but some admin commands can only be run using commandline

there is no way anymore doing that … you could try app occ-web but it will tell you that it’s outdated. And most probably it really IS. So you are on your own responsibility trying to install it.

And please take note that NC tells from the beginning on: We are not made for use on shared hosting. Sometimes it’s all good but if not there could be problems that can’t be solved.

Again: your first person to address to in this case is your hoster. Even more so if they officially offer NC as a hosted solution.

But I am not ready to let you go with that status like that, yet.

Two questions to you to make sure you entered the correct command.
What is your webuser (aka HTTP-User)?
What is the exact installing location (the path) of your nextcloud?

My user name is my
the installation is in public_html
the nextclud user is admn
I restored every thing except data as I did not backup the data
The files are there but it does not show in interface so I suppose I need to rescan
becuase datbase has been restored to old one

Nice username. but I asked for your webuser. The user that your system uses for installing web-related software.

You could find out if you’d enter ls -la in your NC-directory. It’ll show you who owns the files. We need this username.

Sorry if I am wrong again but when I installed the nextcloud the username for interface I used as admin was admn and I have access with that. Is this what you need?

OK the webuser is my I confim

so it should be like that (after you got into your installing directory - it might be important)

sudo -u my php occ app:disable [name of app]

please copy & paste it to your commandline and don’t touch anything else but [name of app].
make sure that you got the correct name of all apps you ant to disable. it’s important that there are no additional spaces in between, no typos, nothing… :wink:

later on you could do the same with app:remove

1 Like