Redis caching on Hepsia

So I am running Nextcloud on a VPS installed via web method now I am wondering how can I get the redis cache setup in my config my host says to use unix:///home/sys/redis.sock to connect instead of ip on port 0 this is my current config

‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘memcache.local’ => ‘\OC\Memcache\Redis’,
‘memcache.distributed’ => ‘\OC\Memcache\Redis’,
‘redis’ =>
array (
‘host’ => ‘unix:///home/sys/redis.sock’,
‘port’ => 0,
‘dbindex’ => 0,
‘timeout’ => 1.5,
But I am getting the attached error. Anyone know how to fix this?

you should use

'host' => '/home/sys/redis.sock',


Is your redis server up and runing?

Much luck,

Yes my server is up and running I tried your solution and got the same error so redis ia built into php and into my panel for ease of setup but my panel says I should be using the unix:///home/sys/redis.sock as the ip not sure if I am doing anything wrong its a linux vps

How should I know how your “panel” looks like?

If you realy want help, you should completely fill out → the support template ←

Much luck,

I tested it and adding UNIX:/// in front of the path should work, at least it does on my Debian setup.

I’m not sure if this is related to pasting into the forum, but it seems you are using an incorrect character for the quotes, and they don’t seem to be identical either.

Try to use the following “single quote” character everywhere:


If it still doesn’t work you are either using a wrong path or the redis service isn’t running, or not configured correctly.

Seems like you’re using the LEFT and RIGHT SINGLE QUOTATION MARK (U+2018 and U+2019)
Correct would be to use the APOSTROPHE (U+0027) everywhere.

1 Like