Red square of death when I try and add a local drive using the "External storages" plugin - Ubuntu Server

Hi. I am getting the dreaded red square of death when I try and mount a local HDD using the “external storages” plugin on NextCloud. I’ve fiddled about for ages but I can’t pinpoint the problem!

I was going to link my supporting images directly but because I’m a new user it won’t let me link more than 2. So instead I have uploaded an album showing:

My fstab
What I see on Nextcloud (the orange square)
Pic showing the drives mounted
My permissions on the mounted folders

Please see link:

Can anybody tell me what I’m doing wrong?

Many thanks!

Do you also have such lines in the log:

Error PHP stat(): stat failed for /tmp/extern/ at /var/www/testcloud/lib/private/Files/Storage/Local.php#140

I also tried to configure a local folder /tmp/extern as external storage. Don’t know what’s wrong.

Anybody have any idea?

Check the permissions of the /media folder. Also take a look into your Nextcloud and webserver logfile.

I am getting this error in my Nextcloud logfile - can anyone tell me what it means!?

stat(): stat failed for /media/hdd1/ at /var/www/html/lib/private/Files/Storage/Local.php#140

EDIT: Fixed it! I was using Docker, and so I just needed to add

  - /media/hdd1:/media/hdd1

To my Docker-compose file - silly me didn’t realise these directories didn’t exist in the Nextcloud container!

1 Like

this is the reason why the forum asks for more information with a template that is nice to be filled in with the first posting about a special problem.

I know. Apologies. In fairness I fixed the problem myself and posted my solution, not sure what else I can do to redeem myself! :stuck_out_tongue:

the least you could do… :wink:

well… you could shave your hair and take a bath in ash& mud … & then post a pic of it :smiley:

or you would just think of it with your next posting under “support” :wink: that would be enough, i guess ^^