RC4 of Nextcloud 28.0.2

The Maintenance release of 28.0.2 is coming next Tuesday, and a fourth RC is now available on our download server.

I am not saying it will be the last RC, for I jinxed it last time :crazy_face:

As always, help with testing is very much welcome!

We updated our servers, did our tests, and the release candidates seem pretty decent. Still, give it a whirl and report back here so we’re even more sure that it’s good to go! If you notice anything out of order, please report back on the appropriate Github repository! :bowing_woman:



28.0.2 RC4


Thanks, hope you know the OnlyOffice bug, which is critical to most users.


I have noticed that I can in Nextcloud 28.0.2 RC4 no longer delete files as a guest via the Guests app . The delete-option is simply missing. Maybe someone would like to take a look at this. But maybe it’s just a bug in the Guests app. In Nextcloud 28.0.1 i can not find the bug. Same guests version 3.0.1

OnlyOffice is not part of the release archive. Please check whether the issue is reported at Issues · ONLYOFFICE/onlyoffice-nextcloud · GitHub, and if not please open a bug report there.

Nextcloud 28.0.2 RC3 still not scrolling on safari :frowning:

That not scrolling Bug persists in Nextcloud 28.0.2 RC3.

All Safari Browsers on all systems are affected Desktop, iPad, iPhone. Last Version and just updated current version 17.3 iOS and 14.3 macOS

Nextcloud 28.0.2 RC4 still not scrolling :frowning:

affected views:

the other apps views / preview Lists are not affected. they do scroll.

Thank you for the new RC

Unfortunately, the update did not solve a number of problems that I encountered after a clean install of version 27.1.5 and then the suggested update to 28.0.1. After installing subsequent RCs for version 28.0.2, further errors disappear, but not mine :frowning:

  1. According to the description for RC3, the problem with the “Could not check for JavaScript support. Please check manually if your webserver serves .mjs files using the JavaScript MIME type.” message should disappear - unfortunately it does not disappear. It would be useful to have a parameter that would allow you to manually disable the message after the test (curl -I https://your.nextcloud.tld/apps/settings/js/esm-test.mjs) has been performed.
    Should I create a new issue? #43153 & #42989

  2. Unfortunately, there is still a problem with changing the template color from the administrator level.
    → Administration → Theming –> Color
    If “Disable user theming” is ON — the template color does not change despite setting a different color
    If “Disable user theming” is OFF — the color of the template changes, but after re-enabling the function, the color returns to the default one
    Should I create a new issue? #43229

  3. When the need for re-authorization occurs in the administration panel, when confirming the operation, and the auto-complete function is enabled (Firefox 122), the username is entered into the “search” field of the menu bar and automatic search is triggered.
    Should I create a new issue?

  4. Suggestion – It would be useful to have a function that would allow to manually clear the error message in “Overview” until the next one appears.

Sorry for any mistakes, I’m new at the NC Help Community.

1 Like

Composer detected issues in your platform: Your Composer dependencies require a 64-bit build of PHP. Rolling back to RC3

Where do you see that?

Thank you for your feedback! :slight_smile:

  1. reply on the original issue first, maybe, but keep the option to open a follow up one in case you get no reply there.

  2. Yes, please open an issue in the server repo, if there is none yet

  3. As in two, but it might also be a thing with the new FF release.

  4. Now this thread is not the place to discuss it, but I am not sure it is helpful to hide errors (out of sight, out of mind).

1 Like

If it is not reported yet, an iusse at Issues · nextcloud/server · GitHub would be great.

Top of the screen after returning from the updater. It’s getting late here, I can update to rc4 again and give more info on Github tomorrow.

I had a similar issue as far as your 1st issue goes. Turns out there isn’t support for self signed certificates in the script that generating that warning message. I’ve commented on the original issue asking for support.


On every occ command AND on the web interface - Nextcloud is completely broken now!

Upgraded from to That’s a STABLE release :warning::warning::warning: …well, at least it was considered as such.

See [Bug]: Composer dependencies require a 64-bit build of PHP · Issue #43157 · nextcloud/server · GitHub please and assist on how to fix this asap. If you spotted this on a RC, how did the stable releases got released at all?

Please… as mentioned:

Nextcloud is down !!!


(hopefully) solved by “downgrading” to (without database or data directory) by

  • restoring $nextcloud-data-dir/updater-ocXXXXXXXXXX/backups/nextcloud- over my /var/www/nextcloud
  • and running occ upgrade afterwards.

Many double checks, backups and tests before and after that included made this freaking update steal me 5 and a half hours of my life time (instead of the usual 10 minutes for minor updates), making this the worst update experience EVER.

Because of this personal experience with a stable (!!!) release AND the fact that

… I currently can’t trust Nextcloud('s update mechanisms) anymore. I don’t hope but expect others to run into this very same issue once the or 28.0.2 update is performed by other 32 bit users. Have fun with that.

I’ll check back in a few weeks once [Bug]: Composer dependencies require a 64-bit build of PHP · Issue #43157 · nextcloud/server · GitHub is hopefully confirmed to be fixed in the 27 channel.

If running in a 32-bit environment and you’re using the optional app suspicious_login you may encounter the message Your Composer dependencies require a 64-bit build of PHP if you upgrade with this app enabled. Please see Nextcloud update to breaks Nextcloud on 32 bit systems - #8 by jtr for details. There is an easy fix.


  • My Nextcloud is running on a 64 bit Ubuntu 22.02 system in Docker
  • I am NOT using the suspicious-login app!

I have just updated from 28.0.1 to 28.0.2 (Stable, not RC4)

The admin page now shows the following 3 errors:

  • Apparently you are using a 32-bit PHP version. Nextcloud requires 64-bit to run well. Please update your operating system and PHP to 64-bit! You can find more information in the documentation.
  • Could not check for JavaScript support. Please check manually if your webserver serves .mjs files using the JavaScript MIME type.
  • Some recommended PHP modules are missing in this instance. For improved performance and better compatibility, it is strongly recommended to install them: bz2. For more information, see the documentation

What do I need to do to fix this?

Thank you, Henning

I’m getting these errors on shared links. (Videos files)

NC 28.0.2
PHP 8.1

Are you sure the docker container has 64bit php?

1 Like

Hmm, perhabs you are right and I dont know. I have a Standard Ubuntu:

Distributor ID: Ubuntu
Description:    Ubuntu 22.04.3 LTS
Release:        22.04
Codename:       jammy

My Nextcloud is running by this yaml-file:

compose yml
version: '3'


    external: false

    image: nextcloud:28.0.2
    container_name: nextcloud28-app
    restart: unless-stopped
    hostname: ***
      - 8080:80
      test: ["CMD", "curl", "-fs", "-S", "--max-time", "2", "http://localhost:80"]
      interval: 60s
      timeout: 5s
      retries: 3
      - db
      - /root/nextcloud28/html:/var/www/html
      - /root/nextcloud28/data:/var/www/html/data
      - MYSQL_PASSWORD=***
      - MYSQL_DATABASE=nextcloud28
      - MYSQL_USER=nextcloud
      - MYSQL_HOST=db
      - REDIS_HOST=redis
      - nextcloud_network

    image: mariadb:latest
    container_name: nextcloud28-mariadb
    restart: unless-stopped
    command: --transaction-isolation=READ-COMMITTED --binlog-format=ROW --innodb-file-per-table=1 --skip-innodb-read-only-compressed
      - /root/nextcloud28/mysql:/var/lib/mysql
      - MYSQL_PASSWORD=***
      - MYSQL_DATABASE=nextcloud28
      - MYSQL_USER=nextcloud
      - nextcloud_network
      test: "/usr/bin/mariadb --user=root --password=*** --version"
      interval: 60s
      timeout: 5s
      retries: 3

    image: redis:alpine
    container_name: nextcloud28-redis
      - /root/nextcloud28/redisdata:/data
      - nextcloud_network
    restart: unless-stopped

What is the right way to determine, if the docker container has a 64bit php??

Many thanks in advance!! :slight_smile:

If you are using the “official” nextcloud image (Docker) try to pull the image again.

The amd64 build was hanging until ~9:30 this morning, so your docker client may have pulled the i386 variant as a fallback instead (I had the same problem).

See also After updating to Nextcloud 28.0.2 Security message: 32bit in use · Issue #2153 · nextcloud/docker · GitHub and https://github.com/nextcloud/docker/issues/2154

1 Like

Hehe thank you! I think, I’ve pulled VERY EARLY in the morning. :yawning_face:

I will read a bit, then “re-pull” images and will give feedback in 2h. :+1:

Feedback: this went successfully. Thanks again!