Random user names

ldap
#1

Hi all,

I installed Nextcloud 16 on a VM and connected to my LDAP. I see the list of users, all of them. But the user names on the Users list turned into something like 1a766401-2b7311e8-841fbcdf-1b2572c4. It is hard to search for them. Then I found here information that says a tag sAMAccountName was needed as the Internal Username in the Expert tab. Then I added a new user via LDAP, hoping to see a proper name on the list of users with proper names. But it did not resolve the problem. What else could be wrong? Please, help!

Thank you.
Yerbol

#2

i am no expert in ldap but i think i do remember a post here in the forum where someone said that these “random” names do indeed look like the UID. so maybe you have just put the identifier wrong?

#3

Thanks JimmyKater. Could you please elaborate which identify to use instead?

#4

i would if i’d just would know it myself without searching the forum… but wells… as i said: i’m not into ldap and short in time as well… so would your mind searching yourself and linking the correct answer to here as well?

thanks in advance

#5

Problem is resolved. The culprit was the encoding that I used for PostgreSQL, which for unknown reasons was left as Unicode. Recreated the database with UTF-8 and everything worked as expected.

1 Like
#6

There is nothing wrong with your setup… This is what LDAP in Nextcloud does… If you are running a test cloud you could fix this before creating users next time…
In your Nextcloud page go to Settings - LDAP / AD integration - Expert. and in the field of “Internal Username” you can write “uid” without the quotations. This will make the username just like you choose it.

1 Like
Change UUID attribute in LDAP setting
#7

darn ali… this seems to be exactly the thing i couldn’t recall and what i think would be a valid solution as well…

thanks for posting this!

1 Like
#8

Happy to be the one helping

1 Like