Quota For Administrator Account

Nextcloud version: 18.0.1
Operating system and version: Debian
Apache or nginx version: Apache
PHP version: 7.3.15

I noticed that it is not possible to set a quota for the administrator account. Therefore I assumed that the administrator account is not affected by any quotas.

But when I later set the Default quota for new users to 0 B, the administrator became unable to create or modify files. It seems that the Default Quota is applied to the administrator account.

Can smb. confirm?

Is this intended behavior? If yes, it would be nice to be able to explicitly set a quota for the administrator, like for any other user.

Steps to replicate it:

  1. Login as administrator
  2. Set “Default Quota” to 0 B
  3. Try to create a file

I found this related thread (NextCloud Version 16.0.4) that never got an answer:

This seems to be related, too:

I use quotas on admin accounts.

@tflidd my question is about how to disable the quota for admin accounts. Are you able to do that, too?

If I click in the quota field, I can select Default quota, unlimited or define a value from the list or specify something myself. That is not different for admin users.

For me - and other NextCloud OPs - it is different: For the (first) admin account there is no way to edit the quota field:

Screenshot taken from HanZ92’s post, here: Can't edit own account under "Users" (including admin)

I just checked on my test setup on NC 18.0.1, it’s not possible any more (it still was on NC 17.0.3). Like in the other topic you linked, please create a bug report on https://github.com/nextcloud/server/issues

If you submit a report, please leave a link in the originial topic: