PSA: How to get collabora working on nextcloud 23!

have the same problem in first

do the dir ritchdocuments/appinfo unchanged for the version 5
the rest of the directorys change with the link
then nextcloud will not update the app

1 Like


1 Like

I can confirm Paradox551install steps worked for me on Ubuntu 20.04 VPS. I did note that when I first opened a document it took minutes for the full interface to load. The side bar appeared straight away but the document took way longer. This resolved after about 5 minutes.

I also found the same problem that “tanc” had so you have to do a clean install and the steps from Paradox551.

The slow loading is still a problem. The side panel loads straight away but the document takes around a minute. I get this SSL error from Open Lite Speed server which looks like a mixed SSL error on the in built proxy so I am starting to think a separate docker instance of Collabora is the only way to go.

2021-12-05 15:17:32.689267 [NOTICE] [1994] [my.ip:53283-Q:7C75C20FA8760739-3936#my.domain] [STDERR] richdocumentscode (proxy.php) error exit, PID: xxxx, Message: No content in reply from coolwsd. Is SSL enabled in error ?

Thank you so much ! I was struggling for several days, searching everywhere (proxy, firewall…) and it ended up that was just the app that didn’t work…
Debian 11 - MariaDB - PHP 7.4 - Apache2 - NextCloud 23 fresh install

I had the same issue on an already installed Nextcloud instance in a VM which I upgraded to 23.

The solution I found was to Disable then Remove the Collabora app from the web interface first.

After I did this, I followed the following steps:


tar xf richdocuments tar.gz

chown -R www-data:www-data richdocuments

mv richdocuments /var/www/nextcloud/apps/

Reload the web interface.

Go into the apps section and allow untested then enable Collabora Online. Make sure you DO NOT UPGRADE Collabora Online to 5.0.0.


Installing richdocument 4.1.2 is a really good workaround! Thank you.

I also run into problems caused by a change in the configuration of apache2.
I use the last collabora docker version.
pls see
“lool” was replaced by “cool”

Collabora Docker works with Nextcloud 23.0.0.

1 Like

Following your instructions the app overview still shows richdocuments as version 5.0

Trying to enable it leads to the error:

Any ideas to bypass that?

This looks like an rights issues.

In my case, all nextcloud files are owned by UID www-data and GID www-data. You should check if the same applies in your case or not. If it’s a different user, change the UID and GID in the command below. Make sure the path to richdocuments is correct because the path from the command below is related to my installation.

chown -R [UID]:[GID] /var/www/nextcloud/apps/richdocuments

Thank you.
I can assure you that i’ve taken care of that. :slight_smile:
I have a CentOS where nextcloud is located under /var/www/html/nextcloud and the user:group is apache:apache.
There was indeed a rights issue but it was concerning selinux, which i’ve fixed too.
In the end the NC-Log still complains about the appinfo/info.xml saying: “filemtime(): stat failed for …”

Unfortunately I’m not so experienced to help with your situation.

I hope you can find a fix.

Updated V23

App Settings are green light and say connected to Collabora Server. The “+” add-file menu has the Collabora Filetypes, let’s me pick a template and create the file.

But then it fails to open.

When clicking on .odt’s it goes to download.


Thank you for the tutorial.
But it is the shame on Nextcloud programmers that a NEW version of Nextcloud is not fully functional after a fresh installation and there is needed a fix like this!

1 Like

I have a similar experience.
I installed NC 23 as docker yesterday.
I am not able to create online any of .odt or .ods documents because there is a template issue.

It’s working! Thank you.

Does somebody was able to run collabora on a pi with arm64 (not VM) ?
I tried both solution:

  • automated install
  • manual install as mentionned by @SitramSoft

For both I have got the same result. Nextcloud is not accessible, it is loading continuously without result.

You need to remove manually richdocuments and richdocumentsserver through the OCC command line.

Setup: PI4_8GB - bullseye_64 - nginx - php8.0 - MariaDb - NC23_native

Thank you so much.

These kinda bugs really undermine my trust in NextCloud tough (and SAAS kinda developement). Been at it for days (and hours) to get this fixed.

It works on Raspberry pi 4. With Apache2, php8, Mariadb 10.6. Manuell installation.
Nextcloud 23 with Collabora 4.2.3 instead 5.0
So it works fine