Problem with mixed languages

Hi everybody,

I set up a Nextcloud for a german client and would like to use the german translation. So I set the following parameter in config/config.php

  'force_language' => 'de_DE',
  'default_language' => 'de_DE',

Unfortunately the language seems to be mixed. When I log in to the cloud it says “Dateien” (correct german word for files) for some milliseconds and then it switches to the english translation and says “Files”.
The same happens with other words which aren’t translated correctly. Words like “Size”, “Shared” or “… days ago” aren’t translated at all, although the parameters seem to be correctly set.

What is the problem? It seems like Nextcloud doesn’t know which language to choose. The translation files in settings/l10n also seem to be correctly translated.

Thanks for your help.

Not sure why you need to set this config side. Each user can set its preferred language.

Try another locale.

See https://docs.nextcloud.com/server/13/admin_manual/configuration_server/config_sample_php_parameters.html?highlight=force_language#user-experience