Problem with loading collabora online. cURL error 28

Hi, I installed Collabora Online, but when I try to open file there is message “Failed to load Collabora Online - please try again later” and record in logs:

          [richdocuments] Error: GuzzleHttp\Exception\ConnectException: cURL error 28: Connection timed out after 5001 milliseconds (see http://curl.haxx.se/libcurl/c/libcurl-errors.html) at <<closure>>
     0. /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php line 149
        GuzzleHttp\Handler\CurlFactory::createRejection(GuzzleHttp\Handl ... l}, {errno: 28,error ... 0})

et cetera.

Request “https://doc.inplay.space/loleaflet/dist/loleaflet.html” is working, but give mistake: “Wrong WOPIsrc” - i think, that apache proxy work well.

OS: Ubuntu 18.04 LTS
NC: 16.0.3
Apache2

I stucked, I would appreciate for any help and ideas, thanks!

Hey Crocodeev,

I had the same problem. My solution was to install the newest version of Docker and to run these 2 commands from the Docker Enginge Docs. https://docs.docker.com/install/linux/docker-ce/ubuntu/

curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
sudo apt-key fingerprint 0EBFCD88
add-apt-repository \
   "deb [arch=amd64] https://download.docker.com/linux/ubuntu \
   $(lsb_release -cs) \
   stable"

sudo reboot

I hope this solve your problem :slight_smile: if not please send us here your Apache Reverse Config :smiley:

regards

matzemagdocker

Unfortunately, it didn’t help for me, this is my apache config

<VirtualHost *:443>
ServerName my.domain.com:443

# SSL configuration, you may want to take the easy route instead and use Lets Encrypt!
SSLEngine on
SSLCertificateFile /etc/ssl/my_domain_com/my_domain_com.crt
SSLCertificateChainFile /etc/ssl/my_domain_com/my_domain_com-bundle
SSLCertificateKeyFile /etc/ssl/my_domain_com/my_domain_com.key
SSLProtocol             all -SSLv2 -SSLv3
SSLCipherSuite ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:E$
SSLHonorCipherOrder     on

# Encoded slashes need to be allowed
AllowEncodedSlashes NoDecode

# Container uses a unique non-signed certificate
SSLProxyEngine On
SSLProxyVerify None
SSLProxyCheckPeerCN Off
SSLProxyCheckPeerName Off

# keep the host
ProxyPreserveHost On

# static html, js, images, etc. served from loolwsd
# loleaflet is the client part of LibreOffice Online
ProxyPass           /loleaflet https://127.0.0.1:9980/loleaflet retry=0
ProxyPassReverse    /loleaflet https://127.0.0.1:9980/loleaflet

# WOPI discovery URL
ProxyPass           /hosting/discovery https://127.0.0.1:9980/hosting/discovery retry=0
ProxyPassReverse    /hosting/discovery https://127.0.0.1:9980/hosting/discovery

# Main websocket
ProxyPassMatch "/lool/(.*)/ws$" wss://127.0.0.1:9980/lool/$1/ws nocanon

# Admin Console websocket
ProxyPass   /lool/adminws wss://127.0.0.1:9980/lool/adminws

# Download as, Fullscreen presentation and Image upload operations
ProxyPass           /lool https://127.0.0.1:9980/lool
ProxyPassReverse    /lool https://127.0.0.1:9980/lool

# Endpoint with information about availability of various features
ProxyPass           /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities retry=0
ProxyPassReverse    /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities
</VirtualHost>

IMHO main socket should be ws:/127.0.0.1 and not wss://, depends on CODE SSL settings (–o ssl-enable=false)

The loleaflet html is only one part of working configuration - and the same error is in my working “productive” config - you should also be able to load the /hosting/discovery site of your config.

You should set also the loglevel in /etc/lool/loolwsd.xml in your CODE container.
And please, do not post real URLs here for security reasons.

Thanks a lot for help, as it turned out, the cause of issue is in the NATs settings. I make some changes in the hosts files in collabora container and host machine. That’s allow communicate collabora and nextcloud in local network.

Can remimber what kind of things has been changed in the NATs settings (in docker hosts file) ? Private/public IP ? Nothing works here. Curl err 28. Thanks