Plugin "file sharing" erzeugt einen Fehler

Hallo,

ich habe schon länger NC, aber vor kurzem habe ich bemerkt, dass ich keine Dateien angezeigt bekomme.

Die Dateien waren aber noch vorhanden.

Da ein file scan nichts brachte habe ich alle APPs deaktiviert und nach und nach aktiviert.

Wenn ich das Plugin “File sharing” deaktiviert lasse, werden die Dateien auf der Weboberfläche angezeigt, wenn es aktiviert ist nicht (“Lade Datei hoch…”)

Wenn aktiviert, dann bekomme ich auch beim file scan die Fehlermeldung

Error during scan: Undefined array key 1

Aber ohne sharing ist NC ziemlich eingeschränkt. Hat jemand eine Idee, wie ich das lösen kann.

  • Bei welchen Anbieter?
    shared host, uberspace
  • Auf welcher Hardware?
    Betriebssystem:
    Prozessor: Intel(R) Xeon(R) CPU E5-2630 v4 @ 2.20GHz (20 cores)
    Speicher: 27.32 GB
  • Betriebssystem sowie Version ALLER beteiligten Systeme
    centos Linux 3.10.0-1160.102.1.el7.x86_64 x86_64
  • Nextcloud Version: [Hub 8] (29.0.0 beta 6)
  • PHP Version: 8.2.16
  • Welche Datenbank? PostgreSQL 15.5
  • Apache version, usw.
  • Läuft NC in Docker,Snap oder VM
    Nein
  • Habt ihr die Logs angesehen von Nextcloud und von System?
    NC logs gibt keinen Fehler oder warnung raus

Das ist ein umfangreicher Fragenkatalog. Nicht immer ist es sinnvoll ALLES zu beantworten. Generell aber sollte gelten, lieber mehr Infos als wenig Infos.

du fährst eine ausgewiesene Beta-Version. Ist das dein Produktivsystem? Ich hoffe nicht!
Andernfalls: Versuch das letzte Backup vor dem Wechel zur Beta-Version einzuspielen. Oder date weiter ab zur RC und schau ob das Problem weiterbesteht. Falls ja, es könnte sich um eine Regression handeln. Bitte dann bei Github den Fehler ausführlich melden und dokumentieren.

NC-Betaversionen sollten wirklich nicht auf Produktivsystemen laufen, weil die eben tatsächlich noch Bugs enthalten könnte.

Jep, ich war da wohl leider so naiv.

Was meinst du mit Regression?

Die Beta-Version muss nicht unbedingt Fehler haben. Ich habe eine Test-Nextcloud mit der aktuellen Nextcloud 29.0.0 RC2 info . Ich habe damit keine Probleme.

a.) Update auf Nextcloud 29.0.0.0 RC2 über den Kanal “beta”
b.) Poste Logfiles, Screenshots, Konfiguraitonen, …

Du kannst nur zurück, wenn du das Backup einer älternen Nextcloud-Version installierst.

für mich bedeutet das: in einer neuen Version funktioniert nicht, was zuvor einmal funktioniert hatte…

Das hatte nichts damit zu tun, dass ich dir empfohlen hatte, auf das letzte Stable-release downzugraden per Backup-restore.

Aber ja, was @devnull sagt… so meinte ich das. Auf RC2 (die gibts seit heute kurz nach meiner Antwort an dich) updaten und schauen ob der Fehler da noch existiert - falls ja: mehr Infos posten

Hallo,

das Update brachte die gewünschte Hilfe. Danke für den Tipp.

Ich habe jetzt wieder auf den “stable” Zweig umgestellt.

Ich gehe davon aus, wenn stable ein höheres Release als mein aktuelles Beta hat, wechsel ich wieder in stable.

Backups vom letzten stable gibt es leider nicht mehr.

1 Like

Ja. Wechsel auf “Stable” sollte funktionieren.