PHP 7.3 issue: can't reach apps page

Hi all,

I’m new to this so I understand only half of what I’m doing, but I’m encountering issues that are not caused by my n00bness. I think.

I’ve been installing Nextcloud via Softaculous.
PHP version was set at 7.3. It worked but navigating to the apps section got me the white screen of death.
I set it at 7.2 and everything worked just fine.

It’s not a real issue since I don’t mind running it under PHP 7.2 but it should have worked so I thought I should report it.

Also I’m experiencing trouble logging in into the Android App. I opened another topic for that but maybe the two issues are related.

Here is some system info: (let me know if you need more)

SSL is working fine on the website. Apparently not with the SQL connection. Could that be the issue?

Oh, and it’s not PHP-FPM. Maybe that has something to do with it?

Hi Sipke,

getting a plain white page, could be a 500 error but this is just me guessing. Please could you look into your webserver logs and see whether it shows any errors? If so, what errors are there while accessing the apps page?

The SQL connection not being SSL secured, should not cause this issue but it’s worth looking at separately, if you want your connection between your website and your database secured. You could google this like “MariaDB SSL connection”, which should give you plenty of guides on how to secure your SQL connection with SSL/TLS

Thanks again @CFelix! I’ll look for webserver logs soon. Have no time to look into it atm.

OK. Remember I am doing this head first without a lot of server knowledge. Apparently I have “suexec error log messages” whatever that is. And it’s saying:

[2020-01-15 04:11:11]: uid: (1489/fluitmai) gid: (1492/fluitmai) cmd: ea-php72

every 30 seconds since I re-installed nextcloud just now. I know that’s not the error you were referring to but maybe it’s related. Either way I should look into it I guess. fluitmai is my account at the host but you probably got that. Please don’t hack me :slight_smile:

I’ll send server error messages as soon as I recreate the problem. Since I have a bunch of them and most are probably unrelated. I’ve been fiddling around with other installs too you know.