401 but I sure know my password

Hi again.

I have a fresh Nextcloud install I want to use in combination with the Anroid App. But Android won’t let me log in and I think it has to do with the server settings. I am a bit of an amatuer and new to this so maybe someone in here can tell me what I should try to change. Or have my host change it. Or switch hosts. It’s kind of a dealbreaker. :wink:

Here is some server information:

php version is native. I have set the PHP of the used domain at 7.2


Maybe it has to do with SSL? It works just fine on the website but apparently not with SQL?

I just now created another topic about my PHP issue. Maybe it’s related.

Hi Sipke,

if you want to login into your user account via an Android/iOS or any other app, you need to create an app password. Doing this is very simple:

  1. Login into your Nextcloud via the website (browser)
  2. Click on your Avatar (top right hand corner), select Settings and click on Security
  3. Here you just enter a name of your choice and click on Create new app password in the Devices & sessions section.

The above steps will show you your username and a random generated password. With these details, you can go back to your Android/iOS/Misc. device and login.

Thanks for your answer @CFelix! For a moment I felt dumb but hopeful. Where is the place I could have found that information?

Anyway. It didn’t work. Not with the qr and not with typing the whole token. It kept on saying:
“Operation finished with HTTP status code 401 (fail)”

Now I still feel stupid. But less hopefull :wink: