Passwords lost and recovery

Hello.

I had a problem with my instance of nextcloud. I managed to keep all my files and hoping the SQL database aswell

Is there a way of getting the passwords out of the sql database. From memory I never encrypted it.

I was using nextcloud snap install with sql lite v5. Not sure on the database user name and password proberly default.

Or are they lost forever. Thank you

If you still have all the files, you can take a look at the backups. Also take a look at the server migration guide to install the backup on a new Nextcloud.

Hi Mate

Thank you for your help, i found the backup file so thankyou for this
i am having this issue any ideas, i tried everything i can think of but no luck
as you can see the file is in the directory and i refreased the datafile with
$ sudo -u www-data php ./occ files:scan-app-data
any more help would be greatly appreciated

image
image

since you already have the backup in the list, you don’t need to import it. Use ./occ passwords:backup:restore <backup name> to restore the backup.

Hi Mate

Hi Sorry i jumped the gun

i didnt put the file name in, can we fix this lol

image

image

Try restoring including the user settings. the app will probably crash if no settings are there at all but data is there.

Hi Mate

Passwords did an Autobackup yesterday the only way i could get it back to work was restore this with --no-user-settings, and it stopped the internal server error

its ok i found an old CSV file with my passwords in it i am missing a few but i have the main ones,

would it cause issues because now im using MYSQL V8 where the snap version uses V5

I can’t follow you right now.

Did restoring the passwords work at all?

Also can you check the Nextcloud log for the error related to that request id?

Hello

i tried ./occ passwords:backup:restore
with all these commands
image

and nothing worked just kept displaying the internal error

there was a an AUTObackup from yesterday, it had no passwords in it because the new instance was still blank so i restored this and with ./occ passwords:backup:restore --no-user-settings and the server came back online.

if you send me an email ill forward the log file for you,
daniel.collins@outlook.com.au