OnlyOffice printing an xlsx has no content only background

Hello,
I have a problem with printing in OnlyOffice (7.3.x): if I try to print a table (only the sheet or selection) I get a PDF without content. I see only background colors or the cell lines. I have not found any setting to change this.
Who has an idea how to solve this?
Thank you!

Good morning Ruebezahl,
I’ve the same issue and it seams to be a problem related the font management.
I found this solution on the web BUT I’m not able to apply this (i don’t know how run this command):
https://community.nethserver.org/t/onlyoffice-print-problem/18449/12.
If You succed please share how to…
Waiting for an Your kind reply
Warm regards
Ale

Hello Ale,

thank you for your answer!
I tried to find this script from your link in my nextcloud server but it doens’t exist.
I will ask this also in the onlyoffice forum.
If I find a solution I give an update here.

Best regards,
Ruebezahl

I think I found the reason why there is no text when printing: the Original XLSX came from Excel and was copied to the cloud. In Excel the standard font is Arial and Arial is not on the Nextcloud server installed. So it shows me the text on screen (but it is not Arial). If I change the font to DejaVu Sans then it works! But it doesn’t work with all font that are listed in OnlyOffice.
I will try to install some other fonts in OnlyOffice. Here is it written how to:

Hi Ruebezahl,
unfortunatly I tried to change font with DejaVu Sans but it doesn’t works.
I tried with all fonts …no way out :frowning:
Ale