I want NC18's Onlyoffice to recognize my fonts

I tried NC18’s Onlyoffice. Please tell me how to make this Onlyoffice recognize the font I added to the server. Collabora recognizes my fonts, but Onlyoffice does not.

This is an impression.
I needed to install two apps, Onlyoffice and Community Document Server.
When I ran Onlyoffice before on docker, Onlyoffice was very demanding of server performance. I gave up using Onlyoffice for that. But the NC18’s Onlyoffice seems to be able to run reasonably well on low-performance servers.


CentOS 7.7

I also installed NC 18, onlyoffice and manually the documentserver v0.1.2. But I even can`t add fonts to the documentserver, because the needed script

/usr/bin/documentserver-generate-allfonts.sh

is missing! So how did you add fonts and how to get the documentserver-generate-allfonts.sh ?

I pulled “documentserver-generate-allfonts.sh” out of the Docker container.
I am not familiar with this. I modified the contents described in that file for myself. It is a statement about the container and the syntax of permissions.
When I ran SH file, I was asked for “libgraphics.so”. I don’t know what this is.

Look here:

  • Community Document Server 0.1.3
  • ONLYOFFICE 4.1.2

In the above version I was able to add fonts with OCC commands.

Hi, which OCC-command? Please post the full CMDlet. Thanks :slightly_smiling_face:

https://github.com/nextcloud/documentserver_community

  • Add font by path occ documentserver:fonts --add /usr/share/fonts/myfont.ttf

I will test it! Many thanks! :grinning:

Using the occ-command,

sudo -u www-data php occ documentserver:fonts --add /usr/local/share/fonts/truetype/cinzel-regular.ttf

I get this error in the terminal:

“There are no commands defined in the “documentserver” namespace”

Any ideas?

Community docucument server app version must be 0.1.3 or later.

alright. works now. Thanks :grinning: