OnlyOffice compiled with Mobile Edit Back

Hello, i need some help please. I need to install onlyoffice without 20 users restrictions. I have downloaded your “files compiled without the Docker Container” build-v5.5.1.
What should I do next to install this onlyoffice compiled version on nextcloud.
Thanks for any help.

Hi. I tried it, but for me it not work.
When i open document, it’s load onlyoffice, but take me Unknown error1

Hey thanks for repo. Thanks for sources.

Hi Nemskiller,
will you build a container for OnlyOffice 6?

Greets from germany

1 Like

There’s a 6.1 compact docker link ^^^^ there somewhere already.

what should i dot in order to change port for onlyoffice during installation and in nginx

I can’t get this docker image to work. I copied my existing docker-compose file and changed the image to match this one but when I start it, it just spits out the following error constantly:

nc: port number invalid:
Waiting for connection to the  host on port

I tried changing the port being forwarded for both local ports (80 and 443) but it doesn’t change the error. I stopped my previous OnlyOffice docker container beforehand so it’s not conflicting.

This version does not work with onlyoffice 6?

I spoke with zegrorax and he Said they patched his patch.

This Docker Image is working fine for me.


i have installed this on my rpi4 (2)
i would like to connect and use it from rpi4 (1)
what should be its nginx conf
can u please guide

Have a look at the first post it has a example nginx config.

Bit random but is anyone else getting this weird font colour bug in spreadsheets? Every bit of text in the screenshot is meant to be black. It only happens on mobile and with any cells that have some kind of font change applied to them (e.g. bold, italic, background colour). It happens with older versions of OnlyOffice and the latest version, but doesn’t happen on the Desktop viewer.

Actually I installed container but was not able to run it.
Can you guide me installing and running it on my rpi4 4gb with Ubuntu 20.10 arm64 running Nextcloud on it.

I’m still using the onlyoffice version mention in the first post. It seems @Nemskiller didn’t update this version since then.

What’s the recommended way to update to a more recent onlyoffice version (without losing mobile edit)?

Somehow mobile editing seems to be back on my instance with the free docker onlyoffice documentserver…

1 Like

I tried today and it’s working

What’s the version number of this build?

It is 6.1.1 afaics.

Just installed the deb from the official repo ( and it also seems to work on mobile again!

Yesterday I spent a whole day to compile onlyoffice (and to get around all those build errors) :/. Seems it was a lot if time wasted ;).

Aand it’s gone again on 6.2.0 :confused:
So most likely only a “bug” on their side in 6.1.1…