OnlyOffice compiled with Mobile Edit Back

My GitHub repo does include a patch for mobile editing, fyi.


thanks a lot, i will look as soon as possible.

who knows where the logs are stored this docker onlyoffice?
/var/log/onlyoffice -empty

For mobile editing it is sufficient to patch the official container with

for f in $ROOT/var/www/onlyoffice/documentserver/web-apps/apps/*/mobile/app.js; do
    sed -i 's/\(isSupportEditFeature:function(){return\)!\(1}\)/\1 \2/g' "$f" \
        && { cat "$f" | gzip > "$f".gz; }

where $ROOT is the filesystem root of the docker container. Aleks does (almost) exactly this and additionally recompiles the server part to remove the 20 connection limit.



I tried to run your latest docker image but whatever I do, it can not start. I get this error message:
OCI runtime create failed: unable to retrieve OCI runtime error (open /run/containerd/io.containerd.runtime.v1.linux/moby/115f63715d5997cdf638c4cb49ebb54d5dcfdcd13a6b7ae279f1289faf5963f0/log.json: no such file or directory): runc did not terminate sucessfully: unknown

And after a few times I tried to start I get this error message:
read unix @->@/containerd-shim/eb094513d1aeaf0c2a69973329d276f09635dbfcffa89fc0ea9be754aa6bb55b.sock: read: connection reset by peer: unknown

And sometimes I get this error:
{"message":"OCI runtime create failed: container_linux.go:349: starting container process caused \"process_linux.go:291: starting init process command caused \\\"fork/exec /proc/self/exe: resource temporarily unavailable\\\"\": unknown"}

Does someone have a clue what’s happening or how I can fix that?

If the question comes up: I am using Ubuntu Server 18.04 LTS (with Plesk 12).
And the official OnlyOffice document server docker image does work well for me, btw.


Seems like this isn’t working in dockerimage v. 5.6.5 anymore. Does anyone know anything about this?

the aleho repository mentioned above appears working on for me as of today, it was patched ~2 weeks ago.
EDIT: I just verified build Version: 5.6.5 (build:3) with > 20 connections and mobile editing are working.

What errors are you seeing?

I meant running the simple script for getting mobile edit back isn’t working in the official image. I will take a deeper look next week.

For me it’s also working normal. Open on multiple mobile devices and editing normally. @AfSZD you who maintain the repository?

Im not the maintainer, no. Just a happy user.

As my browser cached the script files I couldn’t edit from mobile. After cache refresh it’s working in v. 5.6.5.

//And after release of v.6 it’s also working with the new image.

Does this support raspberry pi 4 with 4gb?
Please guide,

Hi. I’ve followed your HOW-TO and it didnt work as expected =( after some digging I’ve found that problem was in rabbitmq start script - it’ can’t create dir in t /var/run with mkdir, dunno why. I’ve replaces mkdir, chown and chmod with install -d -m 2775 -o ${USER} -g ${USER} ${PID_DIR} and it works that way, keep that in mind for future builds. Also big thanks for your work, after they’ve released v6.0 with control panel it became more universal

Hello, does version 6 come with a control panel? where I do to enable it.


First I would like to say that I am a noob on Docker.
Second, I am French, so I have poor English.
Don’t shoot me then :slight_smile:

I have a VPS server under Ubuntu and Plesk (ionos). I installed the docker extension and was able to download your package. On the other hand, I am stuck at the nginx step. I don’t know what to do. Do I need to install an additional nginx docker?

Really sorry for such questions which may sound … stupid.

Onlyoffice updated their manuals here
and you can install control panel from official repo by running
sudo apt-get install onlyoffice-controlpanel

just install nginx and configure it

Thanks for your quick reply.

Is there a risk of installing nginx on the server knowing that it already hosts websites? Could this create a conflict since nginx is a kind of reverse proxy?

well… it won’t conflict with other server if you’ll use another ports


Hmm – do you know the software that is currently being used? Nginx is both a webserver and reverse proxy. If the webserver is already bound to port 80 and 443 then you would have to use other ports.