OnlyOffice compiled with Mobile Edit Back

No, not in the web interface, but you can download the dedicated mobile apps and their source-code appears to be finally available on their github.

In my instance I use self-signed certificate. In web the editor is opened without keyboard, while mobile app doesn’t allow to connect to my Nextcloud or OnlyOffice with the error SSL handshake error. Searching web I found that the self-signed certs are not supported by mobile app. bump (

Hi All, I’ve compiled version 7.2.1 . I’m testing it and seems to work fine.
I’ve made it public and dockerized too.
What’s strange is that in web-apps mobile folder seems empty.

docker pull
docker pull thomisus/onlyoffice-documentserver-unlimited:latest

My setup is everything in a docker compose file with traefik reverse proxy.


I tested the docker and it works with NC24 on my browser, that 's fine.
But if you open the documents on the tablet od on iphone, you get the following error message: Cannot GET /web-apps/apps/documenteditor/mobile/index_loader.html

So the container is not for mobile users, they cannot view oder edit the documents in the cloud. Any ideas for solution?

Regards Sebastian

I know, I’m looking into it… For some reasons web apps are not built/copied to the right folder. As soon as I find a solution I’ll update the docker.

thank you, would you also post here for a change, i will text you.

For folks struggling, there is a black friday free home office licence available with a tweet/facebook post. Details at Black Friday 2022 with ONLYOFFICE | ONLYOFFICE Blog

Can you please try pulling the new docker image and let me know if everything works?


After first look at it everything seems to work.

Hey Thomios,

Desktop Version is working fine.
Opening on Mobile Phone / Tablet with Browser, you can see the Document, but you cannot edit it.
Opening with the Nextcloud App, first it is loading onlyoffice, but then you get an error from nextcloud: document not found. (okay, that seems to be a problem with the nextcloud app, happens now also with onlyoffice6.4)

Regards. When i can help you with logs etc., please write me.

Can you please describe your setup? Maybe I can help.
I tried with 2 different setups and everything is working as intended.

  1. nextcloud + onlyoffice everything in a docker-compose.yml and I can edit from mobile browser and mobile app.
  2. onlyoffice community workspace and I can edit from mobile browser.
1 Like

okay, i tried again on another Server, noch change for mobile editing on my servers:

Following Setup listening on 443
→ apache2 mod_proxy: transports form 443 to 9981
→ bring the traffic from 9981 to the docker on port 80 intern

Apache proxy settings:

SSLProtocol All -SSLv2 -SSLv3
SSLCompression off
SSLHonorCipherOrder on

SetEnvIf Host “^(.*)$” THE_HOST=$1
RequestHeader setifempty X-Forwarded-Proto https
RequestHeader setifempty X-Forwarded-Host %{THE_HOST}e
ProxyAddHeaders Off

ProxyPassMatch (.*)(/websocket)$ “ws://$1$2”
ProxyPass / “
ProxyPassReverse / “

For the Browser everything is fine, mobile is readonly…

If you are using the .deb it is intended. Is onlyoffice running as a docker?
If not type this:

sed -i 's/isSupportEditFeature=function(){return!1}/isSupportEditFeature=function(){return 1}/g'  /var/www/onlyoffice/documentserver/web-apps/apps/*/mobile/dist/js/app.js

This patch is automatically applied in the docker container.

1 Like

i’m using the docker version.
Tried with ipad an iphone:

  • Document now i cannot edit online, now it is not even loading…
  • Spreadsheet is working
  • Presentation is also working, but very poor function, can’t even add a new page

im also using on another instance the old 6.4 official version, this one ist much better in online editing. Also thinking about trying collabora online, maybe it is working better…
I can also give you the test account per private message, you can also have a look.

I Think it is onlyoffice itsself…

Updated my repository to version 7.2.2


How did you fix this?
I’ve taken a look at your different onlyoffice repos but didn’t find anything useful.

  • Did you have to add a custom commit of your own?
  • Did you use an specific tag for build?
  • Maybe you used master branch?

On my tests trying to download:
redirects to a 404 page.

Thank you!

Never mind @thomisus . I see you resorted moving from Ubuntu 16.04 to Ubuntu 18.04 so that you could use Node.js 12 instead of Node.js 10.

This should not be needed at all. That’s why I have opened a bug: .

Let’s see what the OnlyOffice guys reply.

Had some problems compiling too. Can’t remember if it was the same bug. TBH I can’t understand why they use such old versions of everything. If you look at the building process log, you can see a lot of deprecation and security warnings of old dependencies.

The reason is that they need to support quite old Operating Systems during many years.
Some companies have paid for this Long-Term-Support.

So the easiest thing for them is to stick to the oldest version that works in those old systems that, at the same time, also works (in its binary form) in recent systems.

1 Like

Isn’t that a security risk to use such old packages?