OnlyOffice Community Server Mobile Editing in NextcloudApp - make it work again

Hi Devs,

after Updating (0.1.9 to 0.1.10) the Community Server of Only Office I noticed that on an Android Phone I can no longer make changes.
There is a PopUp once that it is only possible with a commercial license.

First other Users should know about it. It is not mentioned one bit in the changelog.

Second this is not how nextcloud should treat apps. Without warning changing such an important feature from yes you can to No, its over now - did you like the preview.

I am now searching how to downgrade this app.
Is it enough to only install old files or do I have to make changes in the database?

Help would be much appreciated.

I hope I can spare other users from this awakning after Update.

Thank you.

My managed nextcloud provider uses the ONLYOFFICE Connector to an own onlyoffice-server with ONLYOFFICE-CE but not the Community Document Server.

In my setup the edit of office documents with ONLYOFFICE in the android app has never worked. First test a few months ago.

Hi @florom

Mobile Editing in Only Office is a paid feature. They changed that at some point in time. As I remember a few weeks after Nextcloud introduced the OnlyOffice Community Server and Mobile Editing became possible directly in the Nextcloud app.

I can only recommend switching to Collabora for anyone, who is upset about this behaviour. If you prefer to use OnlyOffice for whatever reason, there is a HomeServer Licence for €139 / year.

In addition to that, a forum user offered a DockerImage some time ago, in which the limitation was removed. But I have no idea if this is stil is a thing and/or actively maintained…

Hope that helps…

1 Like

Hi @florom, there is a way to disable this limitation on onlyoffice server but I don’t know if it works on this app, I will send you how to disable it.

Hi all,

I think nextcloud offers this feature and for me and my family it is more than enough. It worked perfectly. So no need for a different server.

I did not use onlyoffice over the nextcloud android app so I do not know if it had worked there.
Using the firefox browser on Android it did work.

I did not read about that but I am sorry to hear that.

I liked OnlyOffice more than Collabora. Until know I was really happy with it.

I am now looking in a lot of things I hope a find a solution. I think the easiest way would be downgrading the app but that could turn out to be the hardest way .

Thanks for the hints

Many thanks for that. I could really use a few hints.

(I removed the posts so i can make one for alle relies)

Thanks all

Perhaps you can delete the app an manually install the app again from a download.
But was it really deactivated in this new version?

@devnull yes, this function is limited since maybe onlyoffice server 5.5 ( this app is based on onlyoffice server )

steps to disable mobile limitation :

In a shell on your nextcloud server:
  • nano


( edit the path with the way of your nextcloud folder)

  • crtl+w ( search function)
  • (copy paste it ) isSupportEditFeature:function(){return!1}
  • remove the " ! " to obtain this line : isSupportEditFeature:function(){return 1}

do this for the 2 other document :

  • nano /..../nextcloud/apps/documentserver_community/3rdparty/onlyoffice/documentserver/web-apps/apps/documenteditor/mobile/app.js

  • nano /..../nextcloud/apps/documentserver_community/3rdparty/onlyoffice/documentserver/web-apps/apps/presentationeditor/mobile/app.js

/!\ note : this solution must be reproduced at each update of the application /!\

don’t forget to reset your cookies and cache

maybe restart your nextcloud can refresh the app after changes


Hi all,

That is what I will do in the next days. I will post my findings

Yes, I have two nextcloud installments but cause of a series of misfortune both of them are upgraded. Nevertheless I could verfiy that in 0.1.9 it was possible to edit documents on android firefox.

Hi @Mageunic ,

Thank you for the hints but I could not get it working.
Restarting Nextcloud instance, deleting all history coockies, etc. it did not work.

I fear it won’t be that easy.
I will go deeper in this matter and post my findings.
Hopefully I find a solution.

1 Like

@florom, did you put a space between return and 1? ( after removing the !)

1 Like

Yes, i did.
This could be wrong?


@florom no, this is good :+1:

1 Like

Hi @Mageunic

it works now, i can edit on mobile devices in the browser and in the nextcloud app.
Needless to say I did not change anything (except your suggestions 3 days ago)

I am wondering why the app still passes the integrity check but I am glad that it works.

I will do the same to my second nextcloud and post results (in a few days)

Many Thanks!!!


it works :grinning:

1 Like

I am not able to open excel file or create file after editing file as per shown here,
do i need to go back to 0.1.9 to get it work?
Please guide,

I am on latest nextcloud 22.1.1
cummonty document server : 0.1.1
onlyoffice : 7.1.2


Hi @earth ,

Did you find the problem?

Have you tried Mageunic 's guide for editing?
Probably you have to be outside of your LAN that it works. At least in my setting this is the case due to firewall restrictions.

yes i did that, but onlyoffice get stucked as above.
i have nextcloud installed on rpi4 and community document server on same raspberry pi, using NC + OnlyOffice on ARM64 using qemu - #7 by mbcon for getting my onlyoffice to get working.
Please guide me,


did it run ever?

I have no experience with qemu and I am not sure if using Rasp4 (which is arm architecture) can be used as Community Document server.

I am on 21.0.4 so I do not know if there are changes in 22.1.1 which will break my setup.
Downgrading is never a relieable option.

@Mageunic @florom
I have removed and installed documentserver_commuity again to recheck if it is working on mobile
well on mobile only view if working,
as soon as i changed/modified as per above mentiontion line.
it starts working

Thanks to community for getting this work.

1 Like