No connection to Nextcloud at <url> Operation canceled

#4

@papanito @jithin.benjamin I’ve found a solution. Deleting the account(s) in the sync client and re-adding them fixed it. I don’t know why, but well…

#5

@stdll Thanks for your prompt response. Sorry to mention in my post earlier, I have already tried the option you suggested and it worked but if you Quit the application and try to reconnect you may face the same error :confused:

#6

@jithin.benjamin You’re right, after restarting the PC it won’t sync anymore. :confused: I don’t even know what it was caused by. It started on Friday, but there were no updates, neither server-side or client-side. I suspected the PHP version (using 7.0.x), but it was updated two weeks before, not on Friday. Do you have any errors in your server logs? At the moment I suspect it’s a client thing because I don’t see any errors, neither in the Apache log files nor in nextcloud.log. Maybe it’s time to open an issue on GitHub.

#7

@jithin.benjamin I’ve found a solution in my specific case. My router was at fault. We have a “hybrid” solution, meaning our internet connection is split between DSL and LTE. I’ve restricted connections to the Nextcloud server to DSL and voilà, it works. :smiley: I hope you find a solution as well!

#8

Hey,

did someone found a solution, besinde the Router? It is pretty annoying to configure nextcloud every couple of hours.

Thank you!

#9

I’ve got the same errors on my clients. Also client version 2.2.4. Would also be interested to have a solution

1 Like
#10

I have another solution for you, @WhiteTom and @zisuu! By the way, this solved the problem for me as well, once and for all. :smile: The “router solution” was just an unfortunate coincidence.

Look at this topic:

I noticed that I had very slow login times as well. As it seems, one of our Nextcloud clients at home spammed incorrect login attempts and Nextcloud slowed down all of us (due to the same IP address) to a crawl. I had to wait approximately 30s to log in via the Web interface. Turns out mobile and desktop sync clients hate this and respond with “Operation cancelled”. :unamused: This also explains the strange fact that Nexcloud started working all of a sudden when I switched to my employer’s VPN network - I switched to an IP address that wasn’t slowed down.

So, to solve this, you can turn off the brute force detection, but I’d advise against it. I truncated the brute force detection table and made sure that all devices log in correctly. The following topic may help you:

What I don’t like about brute force detection is that the feature is not transparent at all. The following topic contains some improvements that’ll make it in future versions of NC (hopefully):

2 Likes
#11

I’ve found that whitelisting my IP to nextcloud solves the client login problem for me. You can go to the admin page, then then security tab, and at the bottom is a field to whitelist IPs. I’m going to remove the whitelist in a couple of days and see if it is still resolved.

1 Like
#12

Is there any way to debug this? Can I run the client somehow in verbose mode and get more info about my issue?

I have a hosted server that I pay for and have no admin access to it. I want to file a ticket for them and give them some technical info. How do I do that?

Thank you,
Andrei

#13

Again: I’m in same trouble. From one day to the other, Windows client as well as iOS client stopped working with this same message.

Access via web works fine and no log entries while I attempt to log in/out from the Windows client.

The one thing that I changed was moving my server from OpenVZ to LXC. However, all services are running, it has the identical file system, IP etc and web access works.

Any help to debug this would be greatly appreciated!

#14

This is what I get if I run nextcloud --logwindow

#15

Once I cleaned up the table below all of my clients starting working for this user. I’m not sure what is causing these as the records are from our computers and the nextcloud app has the creds saved. We are also using CODE for editing office documents and using Zimbra Auth. My guess could be if either of those is acting up it counts as brute force attempt.

select * from `oc_bruteforce_attempts

1 Like
#16

I have the same problem !
After I have cleaned up the “bruteforce_attempts” table my clients windows are connected after power on. The problem subsists on Ubuntu clients.

errors log:
[Tue Feb 13 16:53:21.572862 2018] [ssl:warn] [pid 11205:tid 140543244531584] AH01909: nuage.ouvaton.org:443:0 server certificate does NOT include an ID which matches the server name
[Tue Feb 13 16:53:54.410402 2018] [ssl:warn] [pid 13923:tid 140543244531584] AH01909: nuage.ouvaton.org:443:0 server certificate does NOT include an ID which matches the server name

1 Like
#17

Same issue here after updating to nc13.0.0 from nc12.0.4.

Brute force app was not installed. Some clients using http and/or https haven’t experienced issues, but others just can’t connect. If I deleted the account and configure it again it starts syncing, but after rebooting or just closing nextcloud client (Windows version 2.3.2 build 1), i wont connect again.

My nextcloud is behind a nginx proxy, and after installing Brute force app and added the proxy IP to the whitelist, the clients start to syncing again.

Obiously if every client go through the proxy, and the proxy is whitelisted seems that no IP would be blacklisted.

Anyway, by now it seems to be solved.

#18

I confirm white listing the ip of my adsl modem still solves the problem at May 27, 2018
NC 13.02

#19

I can also confirm that whitelisting my router (192.168.1.1) solves client syncing problem as of June 26, 2018. This is despite a fresh install of nextcloud server on ubuntu 18.04, fresh sync with no restoration of databases (and thus no restoration of addons). Bruteforce addon was not enabled by default. Enabling it and adding the above IP to the whitelist solved the problem, all desktop clients can now sync with no problem.

The issue came about roughly 3 weeks ago, not sure why. I don’t think there is a correlation to any specific update client or server side. Web GUI log showed a lot of “Login failed: ‘[user]’ (Remote IP: ‘192.168.1.1’)”.

#20

Hello,

I am new to this I am having the same problem, I have the nextcloud working fine, suddenly the windows or mac client stop making connection and syncing. I am searching everywhere but can not find a solution. I am already frustrated, and want to avoid to recreate again the complete server. but i am still afraid it happens again when I do that.

I just see this post “whitelist the router”. can you please elaborate in this and explain me as a 5-year-old baby. My DHCP server/Router/firewall is a Sophos UTM. Talking to a friend he mentions it might be a DNS issue at my home. But cant find anything related to that.

So if you can guide me thru this, How to get error logs, and how to fix it you will make my day and will be a outstanding linux and php learning process
,
This is my home setup: ISP modem is connected to my UTM sophos/firewall, nextcloud is installed on ubuntu 18.04, on a VM running EXSi. the https certificate is getting from Caddy Server.

Can you please tell me what you do and how?

#21

I just want to confirm after enabling the bruteforce app and whitelist my router and isp modem IP address, everything start syncing again

#22

Hi all,

I am having the similar issue but I am not at home right now to double check but I believe this is also something new.

I have Zorin (Ubuntu 16.04) running on the latest version of Nextcloud server. I have done nothing different and server had been running perfect for about 2 to 3 years. Now all of the sudden (I promise except updating Linux and I had done nothing). My nextcloud server will be offline and I cannot access it fro Linux or Web or Windows desktop. But if I reboot the linux server and it will start working again for a while and then stop.

Has anyone encounter the same thing? (this started in the last two weeks) and now I cannot connect to my cloud at all and sync all the changes as I go alone. Any suggestions would be greatly appreciated.

Thanks,

Brad

#23

It seems like I have issue with apache2 server but it never happened until last two three weeks. Can someone please help me to read through this? Sorry I am using Windows at the moment (Linux).

[Wed Sep 05 14:21:36.302258 2018] [ssl:warn] [pid 27181] AH01906: e52ae06211359775e7e39613bdeec8b1.a9b1bbf4d64fb2c3a21536e8544133d9.acme.invalid:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Sep 05 14:21:36.371975 2018] [ssl:warn] [pid 27182] AH01906: e52ae06211359775e7e39613bdeec8b1.a9b1bbf4d64fb2c3a21536e8544133d9.acme.invalid:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Sep 05 14:21:36.380911 2018] [mpm_prefork:notice] [pid 27182] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured – resuming normal operations
[Wed Sep 05 14:21:36.380960 2018] [core:notice] [pid 27182] AH00094: Command line: ‘/usr/sbin/apache2’
[Wed Sep 05 14:21:43.361887 2018] [mpm_prefork:notice] [pid 27182] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
[Wed Sep 05 14:21:43.462679 2018] [mpm_prefork:notice] [pid 27182] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured – resuming normal operations
[Wed Sep 05 14:21:43.462706 2018] [core:notice] [pid 27182] AH00094: Command line: ‘/usr/sbin/apache2’
[Wed Sep 05 14:21:46.382281 2018] [mpm_prefork:notice] [pid 27182] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
[Wed Sep 05 14:21:46.428163 2018] [mpm_prefork:alert] [pid 27182] no listening sockets available, shutting down
[Wed Sep 05 14:21:46.428170 2018] [:emerg] [pid 27182] AH00019: Unable to open logs, exiting
[Wed Sep 05 14:22:00.860918 2018] [core:warn] [pid 27286] AH00098: pid file /var/run/apache2/apache2.pid overwritten – Unclean shutdown of previous Apache run?
[Wed Sep 05 14:22:00.866136 2018] [mpm_prefork:notice] [pid 27286] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured – resuming normal operations
[Wed Sep 05 14:22:00.866175 2018] [core:notice] [pid 27286] AH00094: Command line: ‘/usr/sbin/apache2’
[Wed Sep 05 14:22:01.179020 2018] [mpm_prefork:notice] [pid 27286] AH00169: caught SIGTERM, shutting down
[Wed Sep 05 16:55:23.438189 2018] [mpm_prefork:notice] [pid 6186] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured – resuming normal operations
[Wed Sep 05 16:55:23.438948 2018] [core:notice] [pid 6186] AH00094: Command line: ‘/usr/sbin/apache2’
[Wed Sep 05 17:36:31.098823 2018] [mpm_prefork:notice] [pid 6186] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
[Wed Sep 05 17:36:31.175499 2018] [mpm_prefork:alert] [pid 6186] no listening sockets available, shutting down
[Wed Sep 05 17:36:31.175505 2018] [:emerg] [pid 6186] AH00019: Unable to open logs, exiting
[Wed Sep 05 17:36:45.294836 2018] [core:warn] [pid 9744] AH00098: pid file /var/run/apache2/apache2.pid overwritten – Unclean shutdown of previous Apache run?
[Wed Sep 05 17:36:45.300268 2018] [mpm_prefork:notice] [pid 9744] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured – resuming normal operations
[Wed Sep 05 17:36:45.300325 2018] [core:notice] [pid 9744] AH00094: Command line: ‘/usr/sbin/apache2’
[Wed Sep 05 18:12:26.957363 2018] [mpm_prefork:notice] [pid 9744] AH00169: caught SIGTERM, shutting down
[Wed Sep 05 18:13:58.283337 2018] [mpm_prefork:notice] [pid 13784] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured – resuming normal operations
[Wed Sep 05 18:13:58.283427 2018] [core:notice] [pid 13784] AH00094: Command line: ‘/usr/sbin/apache2’
[Wed Sep 05 18:14:56.813378 2018] [mpm_prefork:notice] [pid 13784] AH00169: caught SIGTERM, shutting down
[Wed Sep 05 18:15:58.405671 2018] [mpm_prefork:notice] [pid 13942] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured – resuming normal operations
[Wed Sep 05 18:15:58.405763 2018] [core:notice] [pid 13942] AH00094: Command line: ‘/usr/sbin/apache2’
[Wed Sep 05 18:16:38.802050 2018] [mpm_prefork:notice] [pid 13942] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
[Wed Sep 05 18:16:38.872330 2018] [mpm_prefork:alert] [pid 13942] no listening sockets available, shutting down
[Wed Sep 05 18:16:38.872335 2018] [:emerg] [pid 13942] AH00019: Unable to open logs, exiting
[Wed Sep 05 18:16:56.032956 2018] [core:warn] [pid 14198] AH00098: pid file /var/run/apache2/apache2.pid overwritten – Unclean shutdown of previous Apache run?
[Wed Sep 05 18:16:56.037560 2018] [mpm_prefork:notice] [pid 14198] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured – resuming normal operations
[Wed Sep 05 18:16:56.037606 2018] [core:notice] [pid 14198] AH00094: Command line: ‘/usr/sbin/apache2’
[Wed Sep 05 18:17:49.357087 2018] [ssl:error] [pid 14289] [client 64.41.200.103:39344] AH02042: rejecting client initiated renegotiation
[Thu Sep 06 07:36:24.812923 2018] [mpm_prefork:notice] [pid 14198] AH00171: Graceful restart requested, doing restart
AH00112: Warning: DocumentRoot [/var/lib/letsencrypt/tls_sni_01_page/] does not exist
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message