No connection to nextcloud anymore

Hello everyone,
i have installed nextcloud 1,5 years ago on a Odroid HC1 and its works fine with no problems. But today i cant use my nc anymore. I cant connect via internet or via ip in my local network. But i can connect via terminal the server. I updatet my HC1, i have done a restart but the problem is the same. Please help me :frowning:

Okay, i think it has something todo with php. because when i want to look at nextcloud.occ its waiting and waiting on php

Hallo, ich habe seit ca. 1,5 Jahren Nextcloud auf einem Hardkernel Homecloud 1 zu laufen. Es war alles wunderbar. Aber heute zack ich kann weder über das Internet noch über die lokale IP auf Nextcloud zu greifen. Auf den Server kann ich hingegen ganz normal übers Terminal zu greifen, habe schon updates gemacht und auch den Server neugestartet. Aber bisher kein Erfolg. Ich wollte NExtcloud jetzt nicht unbedingt neuinstallieren, weil es tricky war, dass er die HDD als Speicher nimmt und nicht die SD. Ich hoffe ihr habt tipps! Danke

hi @clashftw welcome back to the forum :handshake:

please avoid double posts. I moved your German post into an English one as English is more common…

you are missing the required support template. Please fill this form out and edit into your post.

This will give us the technical info and logs needed to help you in case the machine in question in spitting out errors! Since you’ve provided zero technical details it is impossible to help you as-is. Thanks.

Please use the search - lot of issues have been discussed already

Please show what you tried and which problems you hit so far!

Edit2: For sure you need these informations. Iam really sorry! So here it is:

Support intro

Nextcloud version (eg, 20.0.5): 25.0.6snap1
Operating system and version (eg, Ubuntu 20.04): Ubuntu 22.04.2 LTS (GNU/Linux 5.4.241-417 armv7l)
Apache or nginx version (eg, Apache 2.4.25): cant find apache or nginx (tried with apache2 -v and nginx -v, but its said command not fund) is it maybe not on the system anymore?
PHP version (eg, 7.4): PHP 8.1.2-1ubuntu2.11

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it: its allways there

The output of your Nextcloud log in Admin > Logging:

its empty

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'apps_paths' => 
  array (
    0 => 
    array (
      'path' => '/snap/nextcloud/current/htdocs/apps',
      'url' => '/apps',
      'writable' => false,
    1 => 
    array (
      'path' => '/var/snap/nextcloud/current/nextcloud/extra-apps',
      'url' => '/extra-apps',
      'writable' => true,
  'supportedDatabases' => 
  array (
    0 => 'mysql',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '/tmp/sockets/redis.sock',
    'port' => 0,
  'log_type' => 'file',
  'logfile' => '/var/snap/nextcloud/current/logs/nextcloud.log',
  'logfilemode' => 416,
  'instanceid' => 'ocdsjpu3e4rr',
  'passwordsalt' => 'bvqJU2X+L7lrpkqdGW+rzKQVxfCV5H',
  'secret' => 'OQYUC7A2YBcPvNA1xF4dA8VngVHVf2N/REr4G+jq0X1Hc0kV',
  'trusted_domains' => 
  array (
    0 => 'xxxxx',
    1 => 'xxx',
  'datadirectory' => '/media/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:/tmp/sockets/mysql.sock',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => '8oIqBU6ry13NvP093mLQSpnH4tKXelwQXEmia7CGxCgLlexAAYEBNgkhnR7ae6C5',
  'installed' => true,
  'maintenance' => false,
  'loglevel' => 2,

The output of your Apache/nginx/system log in /var/log/____:

2023-04-27T17:49:40Z nextcloud.apache[11812]: error: cannot communicate with server: Post http://localhost/v2/snapctl: EOF
2023-04-27T17:49:40Z nextcloud.apache[11818]: error: cannot communicate with server: Post http://localhost/v2/snapctl: EOF
2023-04-27T17:49:40Z nextcloud.apache[11824]: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using Set the 'ServerName' directive globally to suppress this message
2023-04-27T17:49:40Z nextcloud.apache[11824]: httpd (no pid file) not running
2023-04-27T17:49:40Z systemd[1]: snap.nextcloud.apache.service: Deactivated successfully.
2023-04-27T17:49:40Z systemd[1]: Stopped Service for snap application nextcloud.apache.
2023-04-27T17:49:40Z systemd[1]: snap.nextcloud.apache.service: Consumed 2.504s CPU time.
2023-04-27T17:50:08Z systemd[1]: Started Service for snap application nextcloud.apache.
2023-04-27T17:50:13Z nextcloud.apache[529]: Making sure nextcloud is setup...
2023-04-27T17:50:14Z nextcloud.apache[991]: Waiting for PHP...


Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.