No apps showing in NextCloud

When I go to +Apps every option I choose returns a blank white screen.

What should I do to be able to see apps?

System information
NextCloudPi version 18.0.3 - I upgraded to this version yesterday evening.

Running on Rasbpberry Pi Model 2b

When I go to +Apps every option I choose returns a blank white screen.

A number of the apps that were working are showing as ‘untested app’

What might be causing this issue?

What can I do to fix the problem?

If you need more details about anything please ask and I will reply.

1… pls search the forum for similar threads as there are some.
2… take e.g. the “news” app - remove it… and reinstall it again., it should work.

Hi @JimmyKater,

Thanks for taking the time to read and reply to my post :slightly_smiling_face:

  1. I did take a look before posting, when I have looked again all I can see are post which say 'disable your add blocker. I am tried accessing NextCloud in Microsoft Edge browser and I still can’t see my apps.

If you could link me to the specific posts that are useful, I would really appreciate that, as it seems as though I am failing to find the useful posts.

  1. Can you link me to instructions on how to reinstall apps please?

I am keen not to break my NextCloud set up as it has all my data on it.

Thanks again for your time and support with this issue.

have you found and tried those ones here?

i can’t give you more hints since you deny to give out more infos about your server, your settings, your configs, logs… etc.

maybe even raspi 2b+ is getting too overloaded with nc… i dunno. all i know is: i wouldn’t wanna like installing it on a raspi 1, now,

you’re right - step by step. first solving first problem.
but in general… i experienced the same thing with some “untested” apps in my instances… i removed (de-installed) them and then they turned up anew and i could re-install them without any flaws. but again: get first problem done first.

Thank you for coming back to reply to my questions again @JimmyKater

I have had a look through the links and it seems like I need to do the following

> Change line 404 in 3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php

> increase 1000 to 10000

> In lib/private/App/AppStore/Fetcher/Fetcher.php

> On line 98 change the timeout from 10 to 30 or 90

> in lib/private/Http/Client.php

> On line 66 change the timeout from 30 to 90

Can you tell me how I access


maybe even raspi 2b+ is getting too overloaded with nc

Yes I agree the Raspberry Pi 2 is getting a little old these days.

What would be a more modern, low cost, low power, small device that I could look to run NextCloud on?

you’d better ssh to your server and then go to that directory and edit said file… be carfeul of the owner of the modified file. - how excacty you’d do that - that’s a linux-question. aunt g. does hold some answers for you in this case.

again you would get wise if you’d only search the forum for answers, yourself…

and whatever you’re going to do: take backups… it might be of help :wink:


I just thought it was important to come back here and document what I have done in case anyone else has a similar problem.

In the end I just downloaded everything from my nextcloud on to my computer hard drive. Luckily I didn’t have a lot stored on NextCloud.

I reinstalled the latest version on of NextCloud on an SD card.

I rebooted my fresh system, and now I have all the apps showing again.

I re-uploaded all my data that I had downloaded from my computer back up to NextCloud.

1 Like

i had the same issue today. i did not want to reinstall, however i did try to clear cookies and cache. that did not work.

i tried to do a hard refresh (shift F5) and that seemed to resolve the issue.