NextCloudPi will not activate on Raspberry Pi 4 8GB

Hello! I recently started trying to get NextCloudPi set up via Docker on my Raspberry Pi 4 8GB, but I’m not having any luck. I’m setting it up through Portainer.

When I start it and navigate to server:80, I get the activation page with the 2 passwords. When I click activate at the bottom, however, it loads continuously and says "NextCloudPi not yet initialized, trying again in a few seconds …”. I’ve let it run for hours, with no change.

I searched around the forums, but couldn’t find any resolutions that worked for me. The replies to this post recommend using nextcloudpi-armhf:1.24.0. When I enter “ownyourbits/nextcloudpi-armhf:1.24.0” rather than “ownyourbits/nextcloudpi-armhf:latest” as the image, however, I get the error that there’s no such image.

Can anyone point me towards anything else I can try to get this to work? Thanks!

Try adding v to the version number like this v1.24.0



Alright thanks, that worked as far as pulling that version goes!

But alas, I’m having the same issue with it. Anything else I can try?