NextcloudPi stops responding when using Nextcloud Win7 x64 client

What logs should I be looking at to understand what is happening?

Nextcloud version (eg, 10.0.2): 12.0.3 (NextCloudPi RPi3 image)
Operating system and version (eg, Ubuntu 16.04): Win7 x64
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.25
PHP version (eg, 5.6): PHP 7.0
Is this the first time you’ve seen this error?: no

Can you reliably replicate it? (If so, please outline steps):
8GB class 10 card formated with SD Formatter and then image burneded with Etcher
After boot, I change the default “pi” password to my own password
64GB USB3 flash drive inserted
Followed the wizard to flash it
Fail2ban also installed
Port forwarding 80/443 done on my home router
LetsEncrypt runs ok, certificates installed, URL is working fine as well
As thi RPi3 is dedicated for NC, I activated the “mount logs in RAM” options

The issue you are facing:
Now I installed the NC Win7 client and copied my OwnCloud folder content into NextCloud folder and waited for it to be synced with the server… This is where my problems start, the NC server stops responding and I have to reboot the RPi constantly to the point of not working anymore even with a reboot (using sudo reboot)

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!): getting access denied. I am not a *nix expert, tried to google it but didn’t find it. Sorry for being a n00b :frowning:

The output of your Apache/nginx/system log in /var/log/____:

I see file locking in the log. How much data are we talking about?

Have you tried the web interface?


Thank you for the reply nachoparker. The amount of data is accurately 39.3 GB, 4,536 Files, 1,555 Folders.
If i close the Nextcloud client after 10-15min the webUI starts responding again.

I left the laptop on for 2 days and most of the data was uploaded, I see on the webUI 35GB used. I closed the NC client, reboot RPi3, let it boot up nicely, launch the NC client again.

Now I saw “Waiting…” for nearly 10min and I got:

I am a little bit frustrated that NC took 2 days to get these synced :frowning: I mean, I kept getting messages that NC server was not responding, then it would start again afterwards, etc… just not stable :frowning: … then again I am not complaining as NCpi is provided “as is”, I didn’t pay so I am also expecting some problems as with any software.

Any ideas how to solve this “file locked” problem?

Thanks in advance for any help and thank you also for providing such an easy way to setup NC for Pi3 :slight_smile:


Install Redis:

Are there many big pictures in the data?

It is interesting that nobody has reported this before, so I would like to see what’s happening and if it is really a matter of installing redis, and why it doesn’t happen to other people.

I suggest you report this on the github issue tracker, and if you are willing to we can try to do some testing and debug it.

I am interested, for instance, to know if this happens as well if you try to upload everything through the web interface.

I also have this issue when I upload a LOT of data and/or large files. Most of the time, it will eventually upload/transfer files. Sometimes I need to reboot my RPi to get it all working.

I am figuring that the large amounts of data and/or large files are just overtaxing the RPi.

ETA: I get locked file issues every so often. Mostly when the file is very large.

ok, so there’s more people seeing this

we should study redis then. I have never seen this before, so I figured it would be nice to save some of the scarce pi’s resources


In my case I have files ranging from few KB to 1.5, 1.6 GB.
I am more than happy to try to help, willing to clean up the mSD and start uploading data again so that we see that “lockup”.
I have serial cable hooked up to the RPi (I prefer using this than to use SSH or TELNET at least in the install/pre-testing phase) and using the “top” command looks like the CPU is more or less ok-ish… again, not a *nix expert so not sure I am reading the output properly.

I really want to get NC working, it has helped me (OC) tremendously to get the exact same data replicated in my 4 work laptops.

Let me know how I can be of any help and I will try my best.



So we need to be a bit patient but we’ll get to this.

Can you replicate if you try to upload the same data at one time from the web interface? this is to rule out different behaviour of the sync client.

But first, I would start from scratch. You can use nc-nextcloud followed by nc-init in the NextCloudPi web to cleanup database and files and start from a clean instance. Then you would have to run nc-datadir again. Or if you prefer, just start from a clean SD card image.

It would be nice to monitor CPU also during the tests

Next, I would try again from the sync client

1 Like


about the topic of redis… I tried to go without it because the pi is quite limited in resources.

For me it always worked fine like that. I don’t use any desktop client, I use the web interface instead and I don’t normally upload several gigabytes at a time.

My thoughts are… supposedly, if you use apcu, then NC gives you file locking from the database. Is that the case? are there other reports like this using a setup similar to this? Is it maybe buggy and unreliable and that would explain what we are seeing?

It’s not hard to add redis to the mix, but according to my reading it should not be necessary, plus APCu seems faster.

Even the NC docs recommend APCu for only a small household instance.


Ok! Sounds like a plan and thanks for the patience, on my end I don’t mind doing this 10, 20 or 30x, I will be happy if the issue or the “stability” is improved in any way.

I ended up flashing the image again to the mSD card and will upload all data with the webUI. Afterwards, I may repeat the whole process again and use the NC app, probably with some screen capture to see if I can replicate the problems.

I will let you know how it went with the upload via webUI.


1 Like

Hi @nachoparker

After the intial config I started uploading the files using the webUI. I dragged all my folders to the browser and waited… took a little time to start but then again it is a lot of folders and files :slight_smile:

I monitored cpu usage with “htop” and seems OK, no major usage at all on the RPi3, left my task manager open but just ignore it. I guess that what really matters is the RPi3 CPU usage.

As the upload takes time, I will leave it overnight and let you know how it went tomorrow morning.


Hi again @nachoparker

This morning I checked that only 610MB have been copied to the server :frowning: … in Admin > Logging i have no log entries.

Maybe this is just a significant large amount of data to be transferred? But as same time I think that the architecture is (or should be) robust enough to handle it no? Here I am trying to tread carefully on my comments when using the word “should” :slight_smile: I can only imagine how hard it is to make NCpi happen.

I think I will retry the Win7 x64 client and at same time monitor the RPi3 CPU usage.
Thanks for the patience,


thanks for your testing.

It is a bit dissapointing, yes.

I have uploaded 2GB files from the web interface without issues in my testing, so I am quite surprised. It didt’nt take too long to upload, several minutes.

Can you try uploading a 1GB file through the web interface and see how long it takes? that is something I have tested successfully, so if it doesn’t go well I am suspecting hardware/network issues

1 Like

Hi @nachoparker

I will continue testing multiple times, I don’t mind the time we spend here as long as you have the time/patience to guide me in the right direction and test methodology.

I am cleaning out the test environment and will upload a single 1.3GB file and see the results. For reference, I have gigabit all over my house, I have installed the network cables myself, multiple laptops, Media Center, NAS all working ok :slight_smile: I think we are OK on the network physical side.

My guess is how NC is dealing with when you drag (from Windows Explorer into webUI) 7 top folders which contain 4542 files and 1555 folders ? :frowning:

Let me give a try with a single big file.


hi @nachoparker

File upload was fine, I even see the transfer speed to be slightly higher:

I will try other files/folders


Out of curiosity, are you using the micro SD in the PI as data storage or an external HDD on USB?
My experience with the PI and Nextcloud was that stability and performance improved when I moved DATA from the micro SD (that also holds OS and swap and all) to the external HDD.


Thank you for the input.

I am using a Sabdisk 8GB Ultra Class10 mSD for the OS/swap to keep the data I use a Toshiba 64GB USB 3.0 flash drive. I also have a USB 500GB HDD available but not using that at the moment as it is a bit of a overkill at the moment (data size wise) :slight_smile:


A “temp” folder I have with 140 files and 39 folders was also ok for the upload via webUI, let me try with another example of 403 files and 43 folders.
Be right back…

Thank you, good testing!

Let’s see if we can find where things break. If we can reproduce that then we can start trying out things

Very helpful testing indeed

1 Like