NextcloudPi on a Rock64

ncp

#41

awesome! just fixing the last details for armbian :wink:


Best cheap hardware to run Nextcloud on?
NCP image for Odroid XU4 / HC1 / HC2. Help wanted to support other boards
#42

Stable release is finally available for Rock64! :sparkles:


#43

alright! I’ll try to build again then!


#44

Good news! I’ll download the latest Armbian image for the Rock64 and reinstall NCP with the script. Will let you know how it goes.


#45

still no luck building


#46

good news! I was finally able to build an image that boots. Will now generate a testing NCP image!


#47

announced

feedback welcome


#48

I will give your new image a try shortly and report back.


#49

No matter what I do I get the following error upon boot:

BUG: spinlock lockup suspected on CPU#1,
lock: 0xffffff8009311438, .magic:dead4ead, .owner: /-1, .owner_cpu: -1


#50

what Rock64 model do you have?


#51

I have the 4Gb ram version. Aside from ram amounts, I’m not sure how else to tell model.


#52

maybe try the official armbian image, see if it boots.


#53

Official image booted up no problem. I redownloaded and flashed the NCP Armbian image but still no luck. Getting the same error message as before.


#54

mmm it is the first time I see this with this image. They have a “stable” image but it’s not yet ready to be reproduced by me exactly, so we might have to wait until they move the source to stable.

I created a quick Armbian 5.45 image without NCP, can you try to see if it boots?

https://ownyourbits.com/downloads/Rock64_testing_plain/


#55

I tested this plain image and got the same error as before.

I did forget to mention that I am running my Rock64 board via Micro SD card and not via an Emmc Module. If that helps.


#56

I am also running microSD.

Well, the easiest is to wait a bit to see when we can get the stable sources. It is unfortunate that there is no way to replicate images but the Armbian guys are working on it. I’m in contact with them.

It sucks to see that at least some models fail to work :expressionless:

Thanks for your feedback. I guess you are left with using the curl installer over the official stable image. It will give you the same results.


#57

Can you point me to that and I’ll give that a try. Thank you.


#58

yes, get the image at https://www.armbian.com/rock64/

and install ncp with

# curl -sSL https://raw.githubusercontent.com/nextcloud/nextcloudpi/master/install.sh | bash

#59

I tried running the install 3 times and keep coming up with the same error(s):

Unpacking socat (1.7.3.1-2+deb9u1
Errors were encountered while processing:
/tmp/apt-dpkg-install-GNmWwS/09-mariadb-server-core-10.1_10.1.26-0+deb9u1_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I included the socat unpacking command so you can see roughly in the script where it’s messing up for me.


#60

that doesn’t make sense. I ran that installer on that image this morning

are we sure you don’t have SD card / power issues? >_<