NextcloudPi Malformed version 22 - can't update

Hi All,
First please let me express how thankful I am that you guys made such a GREAT piece of software! I do appreciate it very much!

I am a little confused in terms of the “latest Version” of Nextcloud in NextcloudPi. In fact I do not know it and can’t seem to find which version is currently used and supported by NextcloudPi.
My Server is running on I did configure the autoupdate settings these days. I know I should have done this when I initially installed the instance. I however didn’t, which is my bad :frowning:

I tried to update manually which turned out in following log entry:
Upgrade cannot skip major versions. Please upgrade one major version at a time

Then I tried “22” as I have 21 running which turned out like so:
Malformed version 22

Other than that I am not seem to run the latest version of Nextcloud, my instance runs just fine on RPi. I however like to be on the latest version just to make backup and restore processes easier.

Would be glad, if someone could help.

Thank you so much for your support

Hi All, this thread helped:

I am running the update to 22.2.2 currently. Was not aware that the .x.x version has to be applied.
Hope this will work out… :slight_smile:

x.x is just a filler. I have no idea on what the exact number combination is.

i had no idea too. I just tried 22 which turned out in an error. I read in the documentation that skipping is not possible and that updates need to be done like 16->17->18, so I did not expect to get an error when choosing “22”. Didn’t expect that the minor update version 22.2.2 is mandatory.
However, after going to 22.2.2 the manual update with “0” worked out as well and I am on So my auto updates should work from now on hopefully.


1 Like

Glad, glad it worked for you and the issue is solved.

1 Like