NextCloudPi Insufficient Storage USB key

Hello everyone,

I am a newbie who doesn’t know much about Nextcloud and servers, so please don’t assume I am an expert. I don’t even know how to access the log files.
I recently installed NextCloupPi server on my Raspberri Pi 3, using the great and easy to use Web user interface provided. It worked quite well for a month and now the synchronization does not work anymore, because of “insufficient storage”.
Supposedly my computer files (30GB) are synced and stored on a 64GB USB key plugged into the Raspberry PI. I don’t understand why the limit has been reached.

On my PC (client) I first synced a folder with the server via my local IP adress But of course when I was outside home the synchronization wouln’t work. So I created freeDNS account Thus my client had second account, synchronising the exact same folder with the same account on the server, but via a different adress instead of So now I deleted the account blabla on the client, but did not gain any free space on my USB key.

How is it possible to investigate why my 64GB key is full whereas I am supposed to be using only 30GB ? Could you please help ?

Error PHP file_put_contents(): Only 442368 of 452673 bytes written, possibly out of free disk space at /var/www/nextcloud/lib/private/Files/Storage/Local.php#218

Nextcloud version 13.0.0

Have you checked your deleted files in NC? Maybe, the deleted, but not yet purged files occupy the missing space on your USB key.

Thank you for your answer.
But how can I check if theses files exist and purge them?

In the files app, there’s a trash can icon down in the left sidebar. Just click on it and the view will display all deleted, but not yet purged files. In that view you can either select single files or all files, and permanently delete them.

Thank you so much for answering.
I did what you suggested but the trash is empty.
Since this problem happened I should have mentioned that the display of the WebUI does not behave properly.
Here is a screenshot. Any idea of what is happening ?

Phew… you won’t get around tackling this from the terminal/ssh. You will thus have to login as your user pi - or whatever user had been configured, when you set up the system, and perform some maintenance on your system.

So first, you need to gain access to the system via ssh. On Windows you can use Putty for that on any other OS, like macOS or any kind of Linux distro, you can use ssh. If you made it into the terminal of your RPi, then we will be able to gather some more information and probably resolve this issue.

As a matter of fact, yesterday I did figure how to gain access to the Raspberry thanks to the TUI with ssh. Otherwise I can connect a keyboard and screen to my Pi. So if you have any suggestion, I will be very happy to try it.

Sure, let’s start with some basics…

df -h

will give you the list of devices and their state in means of space. Then we need to know, where your data folder is located and work from there.

Here is what I get :

Filesystem Size Used Avail Use% Mounted on
/dev/root 30G 1.9G 27G 7% /
devtmpfs 460M 0 460M 0% /dev
tmpfs 464M 0 464M 0% /dev/shm
tmpfs 464M 6.3M 458M 2% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 464M 0 464M 0% /sys/fs/cgroup
/dev/mmcblk0p1 41M 21M 20M 52% /boot
/dev/sda1 60G 58G 0 100% /media/myCloudDrive
tmpfs 93M 0 93M 0% /run/user/1000

Ok… so /media/myCloudDrive holds your NC data. There is either another folder, or the user data folders are directly located in /media/myCloudDrive. Issue a

cd /media/myCloudDrive
du -hs *

and post the result.

31G ncdata
20K ncdatabase
28G ncp-backups

A lot of useless backups ?

Well, I don’t know, if they’re useless, but you they may come in handy some day. However, maybe you can configure this feature, but since I don’t use NCP, I cannot help you on that. You may want to ask this question on the appropriate sub-forum.

Now, let’s see, what’s inside that backup folder…

cd /media/myCloudDrive/ncp-backups
ls -latrh

Here is the result.
I don’t really need the backup as nextcloud is already a bacup for me

total 28G
drwxr-xr-x 1 root root 52 Mar 15 03:00 .
-rw-r–r-- 1 root root 28G Mar 15 05:09 nextcloud-bkp_20180315.tar
drwxr-xr-x 1 root root 54 Mar 18 16:27 …

Can I just delete this backup without corrupting the data base ?

Yes… simply issue

rm -f /media/myCloudDrive/ncp-backups/nextcloud-bkp_20180315.tar

I have deleted this backup but the web UI hasn’t changed.
I am rebooting the Pi and will let you know the result.
Thanks again for your precious help !

It has solved the synchronisation problem, the client does not show errors anymore, which is great !!
But for some reason the Web UI still displays strange characters.

Well, your ncdatabase is also on this USB drive and it might have suffured some damage, but I can’t judge that. Maybe it would be a good idea to create a new topic for this specific issue.

What should this new topic be ? Unusual display ?
I looked for a NCP sub forum but did not find any.
I really did appreciate your help.

Can you create a new user and then check the display of the web site, when logging in as the new user?