NextcloudPI activation failed - RapsberryPi 4B 8G

Hello everybody

I recently bought the new RaspberryPi 4B 8G model and wanted it to use it with Nextcloud.
But I can’t get it to work. On the activation screen, after copying the passwords, I can’t activate it. It tells me Nextcloud is not initialized yet.
After applying the image on the SD card, I added the SSH file and that’ was it. All available updates for Nextcloud and NexcloudPi are installed and no HDD/SSD is attached.

When I try to (Re-)initiate Nextcloud, it tells me Nextcloud is not installed and the available commands are limited.

Not sure if the model is to new and not supported yet, if the image is broken or I’m doing something wrong. I tried to find some things on the internet, but haven’t found anything usefull.

Thanks in advanced for your help and patiance. :wink:
Best regards

Following are some logs and info.

NC-Info

NextCloudPi version  v1.26.0
NextCloudPi image    NextCloudPi_03-28-20
distribution         Raspbian GNU/Linux 10 \n \l
automount            yes
USB devices          none
datadir              /var/www/nextcloud/data
data in SD           yes
data filesystem      ext2/ext3
data disk usage      2.1G/29G
rootfs usage         2.1G/29G
swapfile             /var/swap
dbdir                /var/lib/mysql
Nextcloud check      ok
Nextcloud version    18.0.3.0
HTTPD service        up
PHP service          up
MariaDB service      down
Redis service        up
Postfix service      up
internet check       ok
port check 80        closed
port check 443       closed
IP                   192.168.0.12
gateway              192.168.0.254
interface            eth0
certificates         none
NAT loopback         no
uptime               23min

Output of “systemctl status mariadb.service”

Warning: The unit file, source configuration file or drop-ins of mariadb.service changed on disk. Run 'systemctl daemon-reload' to reload units.
● mariadb.service - MariaDB 10.3.22 database server
   Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/mariadb.service.d
           └─ncp-delay-automount.conf
   Active: activating (start-pre) since Fri 2020-06-12 07:57:40 BST; 7s ago
     Docs: man:mysqld(8)
           https://mariadb.com/kb/en/library/systemd/
  Process: 13798 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=0/SUCCESS)
  Process: 13799 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
  Process: 13801 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= ||   VAR=`/usr/bin/galera_recovery`; [ $? -eq 0 ]   && systemctl set-environment _WSREP_ST
Cntrl PID: 13897 (sleep)
    Tasks: 1 (limit: 4915)
   Memory: 1.1M
   CGroup: /system.slice/mariadb.service
           └─13897 /bin/sleep 20

Checked md5sum of downloaded image?
Posting a downloadlink to the file you used can be useful as can a (pastebin) link to content of ncp.log

Have you tried that? or a reboot?
or manually starting mariadb.service?

Hello Oliver

I used the official download source from “ownyourbits.com” and loaded the tar.bz2-file.
(https://ownyourbits.com/downloads/NextCloudPi_RPi_03-28-20/)
The md5sum is correct. :ok_hand:

After running this command, there was not much of an improvement. A reboot doesn’t change a thing as well.

After manually starting the mariadb.service, the following is noted in the status:

● mariadb.service - MariaDB 10.3.22 database server
   Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/mariadb.service.d
           └─ncp-delay-automount.conf
   Active: activating (auto-restart) (Result: signal) since Fri 2020-06-12 09:08:34 BST; 3s ago
     Docs: man:mysqld(8)
           https://mariadb.com/kb/en/library/systemd/
  Process: 32253 ExecStartPre=/bin/sleep 20 (code=exited, status=0/SUCCESS)
  Process: 32362 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=killed, signal=ABRT)
 Main PID: 32362 (code=killed, signal=ABRT)
   Status: "Waiting for page cleaner"

Jun 12 09:08:34 nextcloudpi systemd[1]: Failed to start MariaDB 10.3.22 database server.

Following is a pastebin of the “ncp.log”.
https://pastebin.com/criy8TDC

I did only copy one block, since it was always the same. The rest was the same message or the note, that commands are not available since nextcloud is not installed.

Best regards :slight_smile:

Did not read the logs, but there may be an issue with ncp version 1.26
See here: Nextcloudpi unusable after update to v1.26, Ports 80 and 443 cannot be opened

Probably @nachoparker should have a look…

That looks like a (harmles but annoying) bug to me, created github/issue

Nothing wrong with ncp v1.26 is only releasing auto-update to NC 18.0.5

1 Like

I also can’t get nextcloudpi to work on my pi 4 8gb. I get a process aborted notification after setting up ncp through curl installer. And whenever i try to install/update a version of nextcloud i get a process aborted notification after mariaDB starts. I tried manual starting mriaDB, but it doesn’t help.