Nextcloud won't save the Collabora online wopi_url setting

I tried to add my Collabora online url using the webui, it won’t save.

I tried using occ:
# sudo -u www-data /srv/nextcloud/occ config:app:set richdocuments wopi_url --value='https://office.mydomain.com' Config value wopi_url for app richdocuments set to https://office.mydomain.com root@nextcloud:~# sudo -u www-data /srv/nextcloud/occ config:list | grep wopi "wopi_url": null

I tried to use the exact same command to save a wopi2_url and it works …

Any idea why ?

I fixed it by setting the value in mysql directly.

Having followed the Nginx guide I faced another issue where the docker collabora server returns an “X-Frame-Options” that forbids it to be displayed in NextCloud’s iframe.

So I added “add_header X-Frame-Options SAMEORIGIN;” in the “location ^~ /loleaflet {” block;