NextCloud VM installation, Can't access Web Interface externally

I have just installed a Nextcloud VM instance following the instructions found here for VMWare Player: Documize

The PC itself is running Windows 10 and Nextcloud as mentioned is running in VMWare Player 17 using the provided OVA file. I ran through the setup just fine and I am able to access the web interface using the internal IP on my server computer. However, when trying to access the web interface from an external network, using either the external IP address or the domain name formatted as:, I am only greeted with the web server “Index of /” page.

On the server computer I am also running a WAMP server on Windows, and I notice that it says Win64 on the “Index of” page. However, when attempting to connect to the web interface externally, I am not running the WAMP server. I cannot figure out why I am able to get to an Index page, however am not able to access the web interface. Is there something more I need to do with the virtual machine to configure this? Is it possible that the WAMP server running on Windows the virtual machine is hosted on is causing issues? I cannot find and other topics to help with my specific issue.

Any tips or advice is appreciated!

  • What about adding “https://” before the address? - Does the nextcloud login screen appear then?
  • do you get log enties in /var/log/apache/access_log as well as in /var/log/nextcloud?
  • Is port 443 opened on Firewall and forwarded to your Nextcloud instance?
  • Did you add the dyndns-URI to the trusted domains in /var/www/nextcloud/config/config.php? - see Configuration Parameters — Nextcloud latest Administration Manual latest documentation
  • Did you retrieve and configure a SSL-certificate f.e. from Letsencrypt? - see item “3” in the guide.
  1. Adding “https://” returns 404, however without it, I get “Index of /”.
  2. I only get log entries when accessing it from the host system (the server computer) the VM is running on, but not from outside IPs as far as I am able to tell.
  3. Port 443 is open and I ran “sudo ufw allow 443” as well to make sure.
  4. The dydns URL is in the trusted domains and seemingly was added during first installation.
  5. I ran the LetsEncrypt setup script and set it to the dydns domain through the script noted in the guide (which TLS was also setup during first installation) and am still unable to access it even with “https:/”

Hmmm - it seems, that either the port forwarding leads to the wrong instance (host instead of Nextcloud guest) or the network settings of the VM are wrong.

Does the issue also appear, if you call the NC from outside, if the computer is not connected with the local network (WWAN only)? Call Nextcloud on your mobile phone, after disable WLAN but enable WWAN.
If it works, the “DNS-rebind” settings of your router are wrong.

If you fill the support template we might get a better overview of your system:

I can see you run PHP 8.0, we never made a release with that version.

So what I think; you made an upgrade of PHP which went wrong, or you never ran the startup script, or you didn’t configure your Apache after you made the PHP upgrade (I can see you run dedyn, maybe reinstall that?)

If uncertain and you aren’t invested in the server (synced files, shares etc) then the best thing is to start over fresh, and follow the instructions carefully.

All the latest VMs can be found here: