Nextcloud VM hangs/stalls during install on Windows using VMWare Workstation

Installing Nextcloud VM-Production on Windows 8.1 using VMWare Workstation Player 14.

Seemed to install properly first attempt, but I didn’t have domain name, so skipped the SSH Certificate setup. Afterwards, obtained Domain name and couldn’t get just the Certification script to run, so I deleted the first installation and did a fresh install of Nextcloud VM version.

Now, it gets to where a dialogue pops up saying what all is going to happen next but just hangs and will not progress. The last message on the screen above the dialogue is: “Getting scripts from GitHub to be able to run the first setup…” The dialogue starts off with, "This script will configure your Nexcloud and activate SSL, but hitting “Enter” key does nothing.

I’ve opened ports on my router and added the VM address to the DHCP server (router).

I’m Windows literate, but not with Ubuntu. Any suggestions?

What OS is running on the VM?

Not sure about all the correct terminology, but my “host” machine is running Windows 8.1, and the VM version of nextcloud installs Ubuntu which runs in/under VMWare Workstation Player.

I’ve tried deleting the nextcloud instance inside of VMWare and re-installing the “Nextcloud_Community_VM_PRODUCTION.ova” script.

I removed all references for the previous installation from my router settings, and when I tried re-installing it was assigned a new internal IP address by my router (DHCP server). It simply will not complete the installation beyond the screen I mentioned above.

Try this …


Give 2GB Ram to the VM.
Setup Ubuntu Server, do a small VM Setup (I don’t know exactly, by pressing F6?)
If the question (during Ubuntu Setup) comes up for the User, name it ncadmin. If the question comes up for computer name chose the first part of your domain i.e. cloud if your DDNS is cloud.xxxxxx.com
Don’t forget the SSH installation.

Connect by SSH to your VM, if you don’t know about SSH, google Putty and install it.
If you are connected via SSH and user ncadmin
Just copy and paste … with the wget
wget https://raw.githubusercontent.com/nextcloud/vm/master/nextcloud_install_production.sh
and after that
sudo bash nextcloud_install_production.sh

Answer the questions and do the steps as advised and the NC will run… in approximately 15 Minutes @ 100Mbit Line.
You have to open also port 80 to get the SSL but in this script you will get the information.

Good Luck

Thank you, I will give this a try. I’m “Windows-literate” but struggle with Ubuntu (though I’m willing to learn more about it). So, some of the terminology is still a little foreign to me.

It looks like you pointed me to a more manual installation of Nextcloud than the automated package offered by “Tech and Me” – which is fully automated, including Ubuntu installation.

If I misstated above, my apologies. Regardless, I think I need to learn how to do a manual installation anyway. While I appreciate the offering from Tech and Me, the directions are lacking for a “Windows” user. For example, it automates the SSL certifticate process but gets to a question asking the installer to approve the machine/certificate being made “public”. I answered “No” because I didn’t know what that meant, which caused the installation to be incomplete, set up for SSL but with no certificate.

Anyway, again, I’m going to try your suggestion and see how that goes and will report back here.

Sad to say, I’m going to have to abandon my effort to complete the installation of Nextcloud using the “Tech and Me” VM package. It installed the first time, but I made an incorrect entry – and didn’t know how to fix it. Ended up deleting the entire installation and trying again, when I hit the roadblock. After waiting a day and trying again, for some unkonwn reason, it progressed past the hang-point. But then I came to a question about whether I agreed to having my machine info made “public” in order to obtain a certificate for SSL access. I declined, which caused me to be unable to log into nextcloud after the installation was complete. Having now spent 3 days on trying, I’m going to look into a complete manual installation.

The script I mentioned is in fact the same script the payed VM is using, it is from Daniel Hansson = Tech and me … I didn’t recognize that you are using the VM.
There is a problem because the VM, for some reasons updates probably will destroy the installation.
If you have bought the VM a couple of weeks ago, you probably will have this problem.

If this is the case, it is not easy to fix for a beginner … (of course I am too) but don’t hesitate to ask questions.

I misspoke previously. Should have said, I’m abandoning the complete automated “Tech and Me” installer package. I later realized that what you linked to is the same installer, less Ubuntu Server automated setup. I’m now trying what you suggested, and I do appreciate it. I now realize that your link is also a script for the Tech and Me installation – after the Ubuntu Server has been installed.

During the nextcloud server installation into VM Workstation, I needed to select “Custom” where I changed memory to 2gb, and processor to 1 chip, 2 core (to match my computer), changed Network Type to “bridged” (which I learned from the automated installation), and drive type to SCSI. I think these are correct.

Working on the installation now.

Ok, installed Ubuntu Server and SSH. Determined IP address (same as when I used the fully automated install) and used Putty to log in. Ran the wget script to install nextcloud from here:

https://raw.githubusercontent.com/nextcloud/vm/master/nextcloud_install_production.sh

When I then run “sudo bash nextcloud_install_production.sh” I get the following error:

“bash: nextcloud_install_production.sh: No such file or directory”

I don’t know much about VMware, but in MS Hyper-V Environment (W10Pro) we need to create a new virtual NIC called "External"
BTW
There is a Windows Based free Cloud. It is different to Nextcloud, but it has some nice features NC don’t have.
It is named Tonido and they have also a free DDNS Service.

Thanks so much for your help. I’ll look into Tonido as well, wasn’t familiar with that.

And thanks in particular to linking to the info about the “likely” problem with the network manager used in VM. Exploring that now.

I am able to SSH into nextcloud installation. So I’m not giving up on this installation (that you offered in post 4) just yet.

This usually means, that bash - the aquivalent to cmd in Windows, can’t find the script. You probaby didn’t run that command within the folder, where the script is located.

did you see that the file was downloaded? or did it get an error message?

Try to ping a domain i.e. ping www.heise.de you can choose that … I’m german :wink:

Actually, the installation of Nextcloud on any linux-based system is really easy. It’s the rest of the setup, like SSL for the webserver and such things, which can be complicated.

I don’t know VMWare Player, but does it support snapshots of the guest VM? If yes, then try a staged approach. First install the OS, then make a snapshot of the VM. Then move on. After any “milestone”, perform a VM snapshot, so you can restart from that point in time, if anything went wrong.

Sorry to sound dumb, but how do I change to that folder?

Well, in the folder where issued the wget command. You were probably running as the ubuntu user and thus the script would have been downloaded to the home folder of that user - or whatever user you used to connect to the server via putty.

You could also run:

cd /tmp
curl -o /tmp/nextcloud_install_production.sh https://raw.githubusercontent.com/nextcloud/vm/master/nextcloud_install_production.sh
sudo bash /tmp/nextcloud_install_production.sh

This would have curl downloading the script to /tmp, where you could then just run it as you tried before.

Hey, loading using curl seems to have worked! Had to install curl first. I’ll post back. Really want to get this working, looks like I’m past the point where it was hanging up before. Thanks to both of you.

I’ll report back how this goes from here.

After running the curl script (or whatever it’s called) it downloaded a bunch of files, then took me to the nextcloud setup where I logged in using pword “nextcloud”. Then it took me right back to the dialogue/message where it hangs. Last statement before the dialogue is:

“Getting scripts from GitHub to be able to run the first setup…”

That’s when I get the box saying:

This script will configure your Nextcloud and activate SSL.
It will also do the following:

│ - Generate new SSH keys for the server
│ - Generate new MariaDB password
│ - Install phpMyadmin and make it secure
│ - Install selected apps and automatically configure them
│ - Detect and set hostname
│ - Upgrade your system and Nextcloud to latest version
│ - Set secure permissions to Nextcloud
│ - Set new passwords to Linux and Nextcloud
│ - Set new keyboard layout
│ - Change timezone

│ The script will take about 10 minutes to finish,
│ depending on your internet connection.

I’ve hit “Enter” and tried waiting for nearly an hour at this point and it just keeps showing the message box.

Sounds like a network issue or maybe an environment issue.
Please enable debug in the scrip (uncomment the debug option at the top of the file) and run it again.

It will tell us more on your situation.

I don’t know how to enable/run debug and/or uncomment it?