Nextcloud sync folder on Windows 10 working properly but not not recognized by one type of third-party application

To start, there is no issue with our setup or the behaviour of my desktop synchronization. It has been working basically flawlessly for the last two+ years through various updates of both the client and server, with the following exception that has always been a problem.

The problem:

We have two similar third-party applications that need access to the Nextcloud folder on Windows. The client folders are located in C:\Users\username\Nextcloud. When opening the folders from within the third-party application (the only way for them to access data from the filesystem), they see all the folders in C:\Users\username (including OneDrive), except Nextcloud. It simply doesn’t show up. All other third-party apps see the folder just fine.

One third-party vendor says “they don’t support sync folders,” which is a lie because OneDrive works no problem and all the settings on the Nextcloud folder are the same as the OneDrive folder. The other says that they themselves actually use OwnCloud sync and they got the folders to show up by sharing them using the Windows share feature: right-click the folder > properties > Sharing > Share… and then share the folder without specifying a user. I tried this, and also tried adding the Everyone user, and tried the advanced sharing option and granting all permissions. Nothing works for me.

Some possible quirks of our setup:

  • client users typically have 0 bytes allocated to them (though I have tested by allowing them adequate space, see next)
  • we use a group folder (though I have tested it with regular shared folders after granting space to the user and, in any event, the issue is with the main Nextcloud folder, not the subfolders)

Any help making the Nextcloud folder available like all other Windows folders would be greatly appreciated. Thank you.

I found Nextcloud folder is hidden for some reason. So displaying “hidden” files in our file manager should work…

Thank you for the reply. Unfortunately this is not my issue.

The Nextcloud folder shows up in Windows Explorer and other applications just fine, it is only in the custom file pickers in these third-party apps. They do not have the option to show/hide hidden files. It is like Nextcloud has applied some kind of flag to the folder that hides it only in certain edge cases.

OK, after a bit of messing about, I figured out a solution. However, not being familiar with Windows, I’m not sure if it’s actually safe, so any further comments would be appreciated.

The reason the file was not showing up in the third-party application file managers is that the Nextcloud folder permissions (Windows “mode”) are set with the -s (system) flag in Windows. You can verify this with the dir command in powershell. This makes the third-party applications ignore the folder.

I have removed the permissions with the following powershell command in the parent folder:

attrib -s .\Nextcloud

Everything seems to work fine now - you just lose the Nextcloud symbol in Windows explorer. Hopefully nothing else breaks I guess? If anyone knows why the system flag is required please let me know.

UPDATE

Actually, in my case, there is a slightly better solution. By setting the read-only flag you maintain the Nextcloud folder icon and the third-party apps can still read the folder:

attrib +r -s .\Nextcloud

Further reading:

https://support.microsoft.com/en-us/help/326549/you-cannot-view-or-change-the-read-only-or-the-system-attributes-of-fo

1 Like