Nextcloud security scanner does not recognize my installed version of nextcloud


#1

Hi,

just found the time to follow all the suggestions on of the warnings that are listed on the general tab of my settings page.

I managed to configure the opcache, install redis and APCU ( or ACPU , dont remember ) and i fixed the non-finished indexes.

After that i was curious and clicked on the “security-scan my system” link.

I got a bad rating : E because the scanner did not correctly identify my installed version of nextcloud -> 14.04

The scanner tells my my installed version is : 9.0.53.0

Is that a known bug?
Am i doing something wrong?

The only thread i found about this is more than a year old and it doesnt reveal a solution.

Any further help is appreciated.

Regards

Joerg


#2

Hey Joerg,
did you check the date, when the last scan was made?
Maybe you have to trigger a re-scan.

John


#3

The tool always tells the result fo the last scan. You need to press “trigger re-scan” to get the actual result. That can take some time.


#4

Thank you guys,

i should have written that i already guessed that.
And i tried the rescan button a couple of times already.

Unfortunately the scanner is not so verbose with me.
If i click rescan it just opens a frame which tells me that the rescan will take some time.
The nothing seems to happen.
No spinning wheel of progress.
No success or failure messages.
The screen stays the same.
Refresh ( reload ) of the page shows the same data.
Closing the tab and navigating to scan.nextcloud.com and startallover gives the exact same results.

Might be i am doing something wrong.
If so, the operation of the scanner should be described a little bit more in detail.

Regards

Joerg


#5

Just found out that i am probably not alone with that problem

https://help.nextcloud.com/t/security-scan-will-not-trigger-re-scan-last-scan-in-2017/42336/2


#6

Re-scan worked fine for me, took a bit more than 5 tho, maybe around 10 minutes to display new scan results (last scan, about 10 days ago it was on 14.0.3).


Maybe clear cache from your browsers might help?


#7

Good idea…

… no help though.

Cleared the cache and even tried it with my other browser ( safari ).
Same result.

I would guess that the rescan will happen even if i close the popup that says “rescan triggered”.
Anyway i left that popup open now for at least 20 min already.
Does not work.


#8

I am having the exact same issue, and my last scan was on the exact same date as yours. I posted here, Security Scan will not trigger re-scan - last scan in 2017


#9

Rescanned this morning and all was well. Shows last scan date of 12/02/2018 at 8:55, and I scanned at 10:36AM ish (my time).