Nextcloud, problems with auto updater

Hello,

here I currently have the Nextcloud server version 21.0.4. When I open the “Overwiew” page as administrator no updatre is shown there. When I load the page again or return to it later, I see an update to 21.0.5.
If I press the “Open Updater” button, I get a page that says nothing except “Initializing” and “Current version is 21.0.4”. Nothing else happens.

Is this problem known and is there a solution?

Do you find any more errors in the logs. It could be that outgoing connections are blocked or there is some other problem you don’t get any response from the update servers.

You can try to start the updater from the command line (if you run on a server):
If you are on a Debian/Ubuntu in the main Nextcloud folder:

sudo -u www-data php updater/updater.phar

Schermafbeelding 2021-10-07 om 08.31.23

Also running into this problem

Could be the problem with Lets Encrypt.
https://letsencrypt.org/docs/dst-root-ca-x3-expiration-september-2021/

Search for a solution: https://help.nextcloud.com/search?q=DST%20Root%20CA%20X3

I think you must delete one CA certificate.

Found a thread on synoforum

" My quest with NC21.0.4…

Login to DSM via SSH and stay root with “sudo -i”

  1. Update /etc/ssl/certs/ca-certificates.crt from fresh updated debian container in docker (or download from my disk https://disk.yandex.ru/d/mQZCH398jFMJoA)
  2. In my case path to NC /volume1/web/nextcloud…
    cd /volume1/web/nextcloud/resources/config
    mv ca-bundle.crt ca-bundle.crt.bak
    cp /etc/ssl/certs/ca-certificates.crt ca-bundle.crt
    chown http:http ca-bundle.crt
    chmod 640 ca-bundle.crt
  3. Open NC in browser, check app and log pages…

That fixed it

1 Like

Type “sudo update-ca-certificates --fresh” into your console an refresh the certificates. Then update your NC.

See also here: https://manpages.ubuntu.com/manpages/xenial/man8/update-ca-certificates.8.html

Problem solved