App store missing

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 22.2.0
PHP version (eg, 7.4): 7.4

Hello everyone,

It is my new NC installation on hosted shared server.
I can’t see the app store in my Nextcloud panel.
It worked grate, I’ve installed some apps after installation and now I only see my installed apps list.

  • I’m logged as admin
  • I’ve tried multiple config.php file modifications as per documentation
  • The app store was visible before
  • I’m not getting any errors, just the app list is not displayed anymore.

Anyone had similar situation or may direct me where to find the solution?

My config.php :

$CONFIG = array (
  'instanceid' => '*****',
  'passwordsalt' => '*****',
  'secret' => '*****',
  'trusted_domains' => 
  array (
    0 => '*****',
  'datadirectory' => '*****',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '*****',
  'dbname' => '*****',
  'dbhost' => '*****',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '*****',
  'dbpassword' => '*****',
  'installed' => true,

screen nextcloud app missing

There is / was a problem (end of September 2021) with an old Lets Encrypt certificate.
Did the access to apps work in the last 20 days?

Nextcloud, problems with auto updater

Hi devnull, thanks for fast reply.

app store worked on September 30 for sure, and went missing somewhere later.

I have a paid SSL cerificate on that domain if that matters, not Let’s encrypt.

The problem was not your but the Lets Encrypt certificate from the Nextcloud server.
In this case there must be deleted DST Root CA X3 vom Lets Encrypt on your server.

But perhaps there is another problem. Post more details.

I will, just let me know what details would be helpful. :slight_smile:

Please post the Nextcloud logs.
You find them in the gui and in the nextcloud installation folder.

I can’t display the Log in NC panel.
I’ve just checked the files at nextcloud/data directory and the nextcloud.log size is over 1.6GB, nextcloud.log.1 is over 270Mb are those files should be that big?

Normally not. I think you can post the last lines. If they are to big move nextcloud.log to nextcloud.log.old and wait for new logfile. If there is a new logfile and you find the infos you can delete the old logfile.

Thanks, did that.
The new file nextcloud.log showed up and it is 12Mb.

I don’t know is it safe to post the whole file here.
Here are some of the info from the file end. (I’ve *** some of the info)
Sorry that it looks like mess in one line, but I don’t have log reader app yet. :wink:

log was here

apparently your instance thinks appstore doesn’t have a valid certificate.

If I remember it right there was a problem with some certificates from nextcloud, recently. But afaik they should be solved in the meantime.

It was discussed on the forum. Maybe you wanna search for it?
Or maybe @devnull knows how to get around that (maybe just rebooting your instance?) - the certificate of is valid until january, 3rd 2022, actually.

Thanks Jimmy, I tought so after reading last lines from the log.
Is there a way to restart NC?
It’s installed on hosted/shared server so I don’t think I can restart it easly. :wink:

      "CustomMessage":"cURL error 60: SSL certificate problem: certificate has expired (see for"

Read this
I think only your shared hoster can delete DST_Root_CA_X3 .
( rm /etc/ssl/certs/DST_Root_CA_X3.pem )

Thanks a lot guys. I’ll try to solve that with the hoster.

Problem solved.
I’ve deleted the DST Root CA X3 section from …/nextcloud/resources/config/ca-bundle.crt file.

Thanks again!