Nextcloud Office with Collabora Online Server - can't open documents under NC 24.0.4

I’ve a Collobora Online Server serving several NC instances.
On the instances upgraded to NC 24.0.4 with Nexcloud Office 6.2 I can’t open office documents anymore.

Document loading failed
Failed to load NextCloud Office - please try again later

From the instances still running on NC 23.0.8 with Nextcloud Office 5.0.7 opening the office documents still work.

There are no errors in the nextcloud.log on this. And also nothing on the logs of the Collabora Online Server. In the Nextcloud Office configuration it shows the Collabora Online Server as connected (green). When checking the communciation on port 443 of the Collabora Online Server

 tcpdump port 443

this shows traffic when checking the connection in the Nextcloud Office configuration.
But no traffic when I try to open an office document.

Hi, same problem here. I have Nextcloud 24.0.4 running and I just installed collabora via docker.
The connection works as shown in Nextcloud admin panel > Office. Also log in to works fine.
No errors shown in apache log.

So I cannot say it worked before. But I did everything according to the documentation. When opening a document it says “loading” and after about 10 seconds it shows loading of the document failed.

Is there anything to get it working or is it a bug in Nextcloud?

please use search function - we had lot of thread short time ago regarding this issue!

this thread and references might help to analyze the issue

I found a procedure which did fix my problems.

  1. Install Collabora Online – Built-in CODE Server App (if not already installed)
  2. Activiate the Collabora Online – Built-in CODE Server (under Nextcloud Office* settings). Test with an office document if this works (it should).
  3. Activate a Collabora Online demo server (under Office* settings). Test with an office document if this works (it should).
  4. Finally (re-)activate your own Collabora Online server (under Office* settings).
    In my case this fixed the problem (on 6 NC 24.0.4 instances) and opening the office documents works now again as it should.
  • no glue why this menu item switches its name from “Nextcloud Office” to “Office” depending on what type of server/service you connect

I tried it, but it does not work for me.
Step 4 reactivating only leads to not able to open the documents again. Built-in and Demoserver are working.

I could solve the problem. I have to start the docker container with only one slash in the domain parameter:

sudo docker run -t -d -p --name=OFFICE -e 'domain=nextcloud\.domain\.com' -e "username=user" -e "password=123456789" --restart always collabora/code

is obsolete for current installations

btw: as described above you don’t need the domain config (anymore) for one-client setups. In other words the first Nextcloud connecting to Collabora is always admitted and you only need to apply the multi-domain config in case you use one Collabora system with multiple applications…

same problem. Collabora admin UI available from external, but opening office file from nextcloud fails.


Completely crazy …
I run NC 25 and facing same issue.

After trying your trick, it works fine … Amazing … I spent some days to find a solution, and this trick solved it … Out of my understanding …


great!! helped my also with NC25…!

1 Like

Great! The trick from bosgold help!! Thanks!

Strange behaviour.
I thought these steps got mine working but then realized that it reverted back to the build-in CODE server when I hit save upon selecting my personal server.