NextCloud Office config broken after update to 24.0.4

I just updated my dockerized installation of NextCloud from 23.0.1 to 24.0.4. I found that the previous settings for my NextCloud Office server (version running under the same docker-compose deployment as NextCloud behind a Traefik reverse proxy) do not work anymore. With NC 23.0.1 I was able to acces the NC Office server from the internal docker-compose network by setting the URL to http://code:9980, where code is the name of the NC Office container. With NC 24.0.4 the same setting does not work anymore: when clicking on a document file the loading in NC Office fails with the message:

Document loading failed
Failed to load NextCloud Office - please try again later

I am forced to go through the reverse proxy by using the external https URL of the NC Office server, e.g., to make everything work. I suspect that there’s overhead in using https here, and I’m not in need of it since both NC and NC Office run on the same machine, so I’d like to restore the previous setting making use of the internal docker-compose network.

So my question is: has something fundamentally changed in NC 24.0 so that my previous setup cannot work anymore, or are there some other/new settings that can restore the 23.0 behavior?

Can you check if there is any communication with port 9980 at all when you open an office document?

tcpdump port 9980

Hi, same problem here. I have Nextcloud 24.0.4 running and I just installed collabora via docker.
The connection works as shown in Nextcloud admin panel > Office. Also log in to works fine.
No errors shown in apache log.

So I cannot say it worked before. But I did everything according to the documentation. When opening a document it says “loading” and after about 10 seconds it shows loading of the document failed.

But with command

sudo tcpdump port 9980

I don’t see anything. Not when opening a document or save settings in Admin panel > Office.

I’ve rune tcpdump as you suggested both on NC and NC Office containers while trying to open a file, but nothing showed up. Using the external URL instead a lot of traffic is shown in the NC Office container.

Same on my NC 24.0.4 servers. Check if the procedure which worked for me, are also working for you.

@bosgold your procedure didn’t fix the problem for me. I still cannot make NC Office work when using the docker internal network.

Do you have a docker volume pointed to /etc/coolwsd? Try without and/or check the log files with docker container logs "your cool container" | grep ERROR or something like this.

No, the container does not have any attached volume. And the COOL logs does not show anything while trying to open a document using the local URL.

By the way, I forgot to mention that when I set the local URL the settings seems to have been correctly saved and a confirmation message Collabora Online server is reachable appears in the settings page. But if I leave the page and come back again then the confirmation message is replaced with an error one saying Collabora Online should use the same protocol as the server installation.. Again, this did not happen with NC 23.0.1.

We have the same error.

Maybe it has something todo with the office app? In the systemlogs i see:

Could not detect any host in DOMAIN/lool/convert-to/png → Didnt collabora change lool to cool? So why does the app try to reach lool?

Full ERROR Logs

{"reqId":"jJdd81HiODW9fhAvNUFY","level":3,"time":"2022-08-25T20:06:38+02:00","remoteAddr":"IPADRESS","user":"USERNAME","app":"richdocuments","method":"GET","url":"/apps/richdocuments/index?fileId=275678&requesttoken=%2B9osbC0EiecEL8dlOBHU4ujp6hmowpPIHOeQfEtVYmo%3D%3Az5VJCVdUvY9KHbNddWWiitGRknjwkPeOLtChMS8UFT0%3D&path=%2FNeue%20Tabelle.ods","message":"Could not find urlsrc in WOPI","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:103.0) Gecko/20100101 Firefox/103.0","version":"","exception":{"Exception":"Exception","Message":"Could not find urlsrc in WOPI","Code":0,"Trace":[{"file":"/var/www/nextcloud/apps/richdocuments/lib/TokenManager.php","line":226,"function":"getUrlSrc","class":"OCA\\Richdocuments\\WOPI\\Parser","type":"->"},{"file":"/var/www/nextcloud/apps/richdocuments/lib/Controller/DocumentController.php","line":174,"function":"getToken","class":"OCA\\Richdocuments\\TokenManager","type":"->","args":["*** sensitive parameters replaced ***"]},{"file":"/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php","line":225,"function":"index","class":"OCA\\Richdocuments\\Controller\\DocumentController","type":"->"},{"file":"/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php","line":133,"function":"executeController","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->"},{"file":"/var/www/nextcloud/lib/private/AppFramework/App.php","line":172,"function":"dispatch","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->"},{"file":"/var/www/nextcloud/lib/private/Route/Router.php","line":298,"function":"main","class":"OC\\AppFramework\\App","type":"::"},{"file":"/var/www/nextcloud/lib/base.php","line":1023,"function":"match","class":"OC\\Route\\Router","type":"->"},{"file":"/var/www/nextcloud/index.php","line":36,"function":"handleRequest","class":"OC","type":"::"}],"File":"/var/www/nextcloud/apps/richdocuments/lib/WOPI/Parser.php","Line":59,"CustomMessage":"--"},"id":"6307ba61bc095"}


{"reqId":"fqQfyjnMm1EfQ3T4jFVQ","level":2,"time":"2022-08-25T20:00:41+02:00","remoteAddr":"IPADRESS","user":"USERNAME","app":"no app in context","method":"GET","url":"/core/preview?fileId=357697&c=fc6ad67d2e0a9d53439a267df7704b9d&x=313&y=313&forceIcon=0&a=0","message":"Could not detect any host in XXXX/lool/convert-to/png","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:103.0) Gecko/20100101 Firefox/103.0","version":"","data":[],"id":"6307ba61bc281"}

Yes, please try to open with empty config volume / xml if you have so

Which config volume / xml do you mean? The .xml fro collabora or which one from nextcloud?

Collabora Online coinfig xml