Nextcloud Hub 6, 27.1.2 and Collabora online not working with memcache

Today I installed the redis server on ubuntu server with redis sock for Nextcloud Hub 6, Version 27.1.2. Before I had only APCu cache and Nextcloud office worked fine. After installing the memcache, with redis (no errors alerts) I got alert from users they can’t download office documents anymore . I tried it myself and coudn’t open a document - error. Same with download. So I removed redis in config.php restarted apache2 and now it works fine, but I get the warning of missing memcache. How can I get the collabora online and Nextcloud office working with memcache redis?

Collabora Online works fine with redis.

Likely you missed something and your memcache integration was broken. Once you configure redis you can monitor if it’s used with redis-cli MONITOR you should see some lines when you are browsing in your Nextcloud instance.

I had errors with the redis-server when I tried to use redis with the unixsocket.
The Problem was that I had no directory var/run/redis/, so “‘host’ => ‘/run/redis/redis-server.sock’,” coudn’t create the socket.
Created the directory change redis.conf and restarted the redis
Checked as follows (thanks for this hint):
redis-cli -s /var/run/redis/redis.sock monitor
configured the nextcloud.conf for memcache as recommended in documentation. And now it works right even with collabora online no errrors anymore.

This representation shows a misunderstanding of how it works.

You propably did not configure redis-server corectly.
The directory structure under /run (symlink under /var/run) is not persistent, it is on tmpfs, so inside of memory and after each server-restart those entries will be lost.

They get all created automaticaly by the deamons supervised by systemd.

So you have to edit your /etc/redis/redis.conf corectly, so that the socket can get created by redis itself.

These are (beside others) the settings needed to get a socket:

bind ::1
protected-mode yes
port 0
unixsocket /run/redis/redis-server.sock
unixsocketperm 770
daemonize yes
supervised auto
pidfile /run/redis/

And you have to add your webserver-user www-data to the redis group:

usermod -aG redis www-data

If you have done everything like above, then you must simply restart your redis server with systemd:

sudo systemctl restart redis-server

and you can see the status with

systemctl status redis-server --no-pager

Much luck,