Nextcloud failed to complete 12.0.3 update Error:" Checking for update of app "activity" in appstore

Nextcloud version: 12.0.3.12 trying to update to 12.0.3
Operating system and version: Ubuntu 12.04.5 LTS
Apache or nginx version: Apache unknown version (shared hosting)
PHP version: 7.1 fast cgi
Is this the first time you’ve seen this error?: yes

Can you reliably replicate it? (If so, please outline steps):

Started update via web updater
updater completed the initial steps, went to the next screen (Blue, start update screen)
Update fails, detailed logs shows this as the last entry: "Checking for update of app “activity” in appstore"
Try to reload the page, get maintenance mode page
Set maintenance mode to false in config page
Try update again from blue screen, same error, same spot

Deleted the activity folder from apps, tried again, same result

The issue you are facing:
Unable to complete update, or exit the update to go back to the current version

The output of your Nextcloud log in Admin > Logging:
Unable to access admin page currently

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php $CONFIG = array ( 'instanceid' => 'oc85th3yd683', 'passwordsalt' => 'x', 'secret' => 'x', 'trusted_domains' => array ( 0 => 'x.x.com', ), 'datadirectory' => '/home/user/x.x.com/data', 'overwrite.cli.url' => 'http://x.x.com', 'dbtype' => 'sqlite3', 'version' => '12.0.3.1', 'logtimezone' => 'UTC', 'installed' => true, 'updater.release.channel' => 'beta', 'updater.secret' => 'x', 'maintenance' => true, 'theme' => '', 'loglevel' => 0, 'mail_from_address' => 'admin', 'mail_smtpmode' => 'php', 'mail_smtpauthtype' => 'LOGIN', 'mail_domain' => 'x.com', ); The output of your Apache/nginx/system log in `/var/log/____`: Insufficient permission to access the file /var/log/syslog --- As I'm unable to execute the .occ upgrade cmd, I suspect the answer here is to blow it away and start over, but I'd hate to have to do that

In your nextcloud data/appdata_<instanceid>/ there should be a folder related to the updater, maybe it is even called “updater”. Try to move it outside to reset the updater state and try to start nextcloud again (with maintenance mode off). But I don’t know if the updater stuck in updating the core apps, which could result in non working/compatible core functions. So for in case keep the mentioned folder to move back in, if it doesn’t work.

@pmcfarland: Hello, updating NC from 12.0.0 to 12.0.3 using web updater I got exactly the same result. The suggested deletion of the updater folder didn’t solve it for me. I’m glad my backups worked. So at least I have my 12.0.0 installation working again. Did You find a solution or could locate the problem? Best regards

Nextcloud version: 12.0.0 trying to update to 12.0.3
Operating system and version: Synology DSM DSM 6.1.3-15152 Update 4
Apache or nginx version: Apache 2.4
PHP version: 7.0

Hello, same issue here

Ubuntu: 16.04
PHP 7.0
Mysql 5.7
Nextcloud web-updater from 12.0.2 to 12.0.3

The suggested deletion of the updater folder ALSO didn’t solve it for me.
So I deleted the whole nextcloud folder and database and restore my folders and databaseb backups to get an running nextcloud instance. NICE

Hi, i solved the problem via this thread.
The fix is written for 12.0.1 but it worked also in this case.
Good luck!

Die Lösung steht hier: Nextcloud 12.0.1 stable Error: Cannot access private property
Ich habe via Web-FTP in der Datei /nextcloud/apps/files_accesscontrol/lib/Operation.php die Zeilen 84 und 85 gelöscht und mit dem empfohlenen Fix überschrieben:

        $hasMountPoint = $storage instanceof StorageWrapper;
  	if (!$hasMountPoint) {
  		$ref = new \ReflectionClass($storage);
  		$prop = $ref->getProperty('mountPoint');
  		$hasMountPoint = $prop->isPublic();
  	}
  	if ($hasMountPoint) {
  		/** @var StorageWrapper $storage */
  		$fullPath = $storage->mountPoint . $path;
  	} else {
  		$fullPath = $path;
  	}

Nun noch vor dem Neuladen der Nextcloud-Webseite in der Datei /nextcloud/config/config.php den Parameter ‘maintenance’ auf ‘false’ zu setzen.
Danach lief es bei mir.

Wenn es euch geholfen hat, dann bitte diesen Beitrag als Lösung markieren, Danke!

@FelixBerlin: Du hast dies nach dem eigentlichen Update getan?
You did this after the update?

Ich wollte Deine Lösung nachvollziehen und muss berichten, dass der Fehler nicht wieder aufgetreten ist. Das Update lief völlig problemlos durch. Im Ergebnis kann ich nicht beurteilen, ob die vorgeschlagene Lösung geholfen hätte.
I started the update to try Your solution. But this time the update worked without any error. So at last I can’t say if Your solution works.

Trotzdem besten Dank!
Thank You nevertheless!