Nextcloud desktop client can't access external drive on Ubuntu

Nextcloud version (eg, 20.0.5): Latest one, downloaded yesterday
Operating system and version (eg, Ubuntu 20.04): 20.04.3 LTS

The issue you are facing:
I have a working Nextcloud server and a working Windows desktop client syncing succesfully.
I’m trying to add an Ubuntu machine to my setup but when I try to use the desktop client for my Ubuntu installation, I get a “could not read the contents of Mydrive” “permission denied” error when I try to select my external hard disk as the drive to sync to.

permissions denied

You’ll need to google and adjust your permissions since you cannot write/read to that drive.
The issue is between Ubuntu and your external disk.

edit: I find your explanation extremely vague & confusing, so might have misunderstood what you are asking.

@Ecation
I understood your problem somehow differently than @just . Maybe you can post some screenshots.

Hi!

Here are some images:
Step 1 I have installed the client and next I will try to set up a folder:
step1

Step 2: I get an error message when trying to select my external hard drive as the target folder:
step2

The problem in a nutshell is that I can’t use my external hardisk with the Nextcloud client. My operating system is Ubuntu.
I also think it’s a permissions problem, but I have no idea what do to. The only search results were about configuring the server, but this is about the client.

Look up external mount disk permissions

You’ll want to edit fstab with the proper permissions. Or re-mount r/w as linked

example
Your disk is known to the system as /dev/sdb1 and is mounted read-only (the ro between brackets). Moreover, it is NTFS (which the mount command reports as fuseblk).
Unmount your disk and re-mount it as read-write, like this:

sudo umount /dev/sdb1
sudo mkdir /mnt/mydisk
sudo mount -t ntfs -o rw /dev/sdb1 /mnt/mydisk 

Thank you for your help.
I feel like I don’t know Linux well enough, things that seem so simple to others give me a lot of trouble.
I think my external hard disk is at /dev/sdc2 and the type of it says “Microsoft basic data”
It also has a red text saying “Partition 1 does not start on physical sector coundary”.

I ran what you suggested (I hope I modified it correctly to use sdc2 instead of sdb1), but now the external hard disk disappeared from the other locations list. I don’t know where it went. Edit: Found it now under mnt/mydisk. But when I try to browse to /mnt/ with Nextcloud instead of the regular Ubuntu file browser, I get another “Error opening directory ‘/mnt’: Permission denied”.

When I right click on my external hard disk and choose “properties” it says that the file system type is “fuse”. Could that be a problem since you mentioned “fuselbk”?

I won’t be able to help you further as I do not use NTFS partitions or anything similar from Microsoft for many years. Good luck. Others with more recent experience should be able to assist you with your permissions.

Would it help if I formatted my hard disk to a different format? Which format would you recommend?

Most common format in a standard linux distribution would be ext4
NTFS format support for Windows was recently added into Linux kernel, but not arriving until kernel 5.15

Hi!

I formatted the disk as Ext4 now but I still get the very same permissions error. :confused:

Am I the only one having permission errors with external disks and the Nextcloud client on Linux?

You have to define the permissions that the disk will use.

Hi!

Thanks again!

I turns out I could fix the problem by removing the Nextcloud client that I installed from the Ubuntu Software center. Instead I installed the version that is recommended on the Nextcloud documentation page. I used the following commands:

sudo add-apt-repository ppa:nextcloud-devs/client

sudo apt-get update

sudo apt install nautilus-nextcloud